aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorYuqing Zhu <b54851@freescale.com>2015-08-10 11:41:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-11 08:51:58 -0700
commitd0b5780125926eb33cc82f17c679e16e64312478 (patch)
tree8d1af3e6e16c770782e3b5f8190da6d6eec055b4 /meta/recipes-multimedia
parent0690a52bf48543351cdc85d2b3c8068d54b51768 (diff)
downloadopenembedded-core-contrib-d0b5780125926eb33cc82f17c679e16e64312478.tar.gz
gstreamer1.0-plugins-base: Update video alignment after video alignment
Video buffer pool will update video alignment to respect stride alignment requirement. But haven't update it to video alignment in configure. Which will cause user get wrong video alignment. Signed-off-by: Yuqing Zhu <b54851@freescale.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rwxr-xr-xmeta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/videobuffer_updata_alignment_update.patch53
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.4.5.bb1
2 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/videobuffer_updata_alignment_update.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/videobuffer_updata_alignment_update.patch
new file mode 100755
index 0000000000..8cfda955a7
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/videobuffer_updata_alignment_update.patch
@@ -0,0 +1,53 @@
+commit 88d253ea23b06289df40401160b606323f16c910
+Author: Song Bing <b06498@freescale.com>
+Date: Mon Dec 15 09:34:35 2014 +0800
+
+videopool: update video alignment after video alignment
+
+Video buffer pool will update video alignment to respect stride alignment
+requirement. But haven't update it to video alignment in configure.
+Which will cause user get wrong video alignment.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=741501
+
+Upstream-Status: Backport [1.5.1]
+
+Signed-off-by: Song Bing <b06498@freescale.com>
+diff --git a/gst-libs/gst/video/gstvideopool.c b/gst-libs/gst/video/gstvideopool.c
+index 4475f45..acef594 100644
+--- a/gst-libs/gst/video/gstvideopool.c
++++ b/gst-libs/gst/video/gstvideopool.c
+@@ -167,6 +167,7 @@ video_buffer_pool_set_config (GstBufferPool * pool, GstStructure * config)
+ /* get an apply the alignment to the info */
+ gst_buffer_pool_config_get_video_alignment (config, &priv->video_align);
+ gst_video_info_align (&info, &priv->video_align);
++ gst_buffer_pool_config_set_video_alignment (config, &priv->video_align);
+ }
+ priv->info = info;
+
+diff --git a/sys/ximage/ximagepool.c b/sys/ximage/ximagepool.c
+index 6cc2cfa..6a1cbc9 100644
+--- a/sys/ximage/ximagepool.c
++++ b/sys/ximage/ximagepool.c
+@@ -597,6 +597,8 @@ ximage_buffer_pool_set_config (GstBufferPool * pool, GstStructure * config)
+ /* do padding and alignment */
+ gst_video_info_align (&info, &priv->align);
+
++ gst_buffer_pool_config_set_video_alignment (config, &priv->align);
++
+ /* we need the video metadata too now */
+ priv->add_metavideo = TRUE;
+ } else {
+diff --git a/sys/xvimage/xvimagepool.c b/sys/xvimage/xvimagepool.c
+index 244a51a..34b1ab2 100644
+--- a/sys/xvimage/xvimagepool.c
++++ b/sys/xvimage/xvimagepool.c
+@@ -124,6 +124,8 @@ xvimage_buffer_pool_set_config (GstBufferPool * pool, GstStructure * config)
+ /* do padding and alignment */
+ gst_video_info_align (&info, &priv->align);
+
++ gst_buffer_pool_config_set_video_alignment (config, &priv->align);
++
+ /* we need the video metadata too now */
+ priv->add_metavideo = TRUE;
+ } else {
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.4.5.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.4.5.bb
index aa9017906a..88c3254fc6 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.4.5.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.4.5.bb
@@ -10,6 +10,7 @@ SRC_URI += "file://do-not-change-eos-event-to-gap-event-if.patch \
file://taglist-not-send-to-down-stream-if-all-the-frame-cor.patch \
file://fix-id3demux-utf16-to-utf8-issue.patch \
file://handle-audio-video-decoder-error.patch \
+ file://videobuffer_updata_alignment_update.patch \
"
SRC_URI[md5sum] = "357165af625c0ca353ab47c5d843920e"