aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-08-22 08:58:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:34:09 +0100
commit47212cb032b67dc59277f6c38e9aeda5a9b628a4 (patch)
tree0914f000077cc7ce1bd50d0ef2242c53e6d69ba3 /meta/recipes-multimedia
parentfc35c10fed382e385f00b76abcee94a0148b4aee (diff)
downloadopenembedded-core-contrib-47212cb032b67dc59277f6c38e9aeda5a9b628a4.tar.gz
alsa-lib: Lift the limitation to use gcc only cross compiler
alsa-lib configure tries to see that if CC variabled doesnt contain 'gcc' then it tries to guess and redefine CC to be something gcc, which doesnt work with OE since we define CC to have sysroot and options attached to it. So all tests fail when configure constructs the CC for cross compiler like this. This portion is not needed at all (From OE-Core rev: 33a7eb64cded61601c6ad6883e4d64ebe9ff547c) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib/0001-build-Do-not-try-to-detect-cross-compiler.patch45
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib/0001-build-Do-not-try-to-detect-cross-compiler.patch b/meta/recipes-multimedia/alsa/alsa-lib/0001-build-Do-not-try-to-detect-cross-compiler.patch
new file mode 100644
index 0000000000..583bc3daab
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib/0001-build-Do-not-try-to-detect-cross-compiler.patch
@@ -0,0 +1,45 @@
+From 17aeb3565f411e7796cabe403f92d15948a8ca95 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 21 Aug 2015 14:42:45 -0700
+Subject: [PATCH] build: Do not try to detect cross-compiler
+
+cross compilers are passed via path may not be a gcc based cross
+compiler in such cases this check fails and try's to force gcc based
+cross compiler detection, This code is a convenience that limits the
+build system
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ configure.ac | 14 --------------
+ 1 file changed, 14 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3022cf8..9d77440 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,20 +27,6 @@ AC_PREFIX_DEFAULT(/usr)
+
+ dnl Checks for programs.
+
+-dnl try to gues cross-compiler if not set
+-if test "x$host" != "x$build" -a -z "`echo $CC | grep -e '-gcc'`";
+-then
+- AC_MSG_CHECKING(for cross-compiler)
+-
+- which ${program_prefix}gcc >/dev/null 2>&1 && CC=${program_prefix}gcc
+- which ${host_cpu}-${host_os}-gcc >/dev/null 2>&1 \
+- && CC=${host_cpu}-${host_os}-gcc
+- which ${host_cpu}-${host_vendor}-${host_os}-gcc >/dev/null 2>&1 \
+- && CC=${host_cpu}-${host_vendor}-${host_os}-gcc
+-
+- AC_MSG_RESULT($CC)
+-fi
+-
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+
+
+--
+2.1.4
+
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb
index fc6ba693f5..730f427402 100644
--- a/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.0.29.bb
@@ -16,6 +16,7 @@ ARM_INSTRUCTION_SET = "arm"
SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2 \
file://Check-if-wordexp-function-is-supported.patch \
+ file://0001-build-Do-not-try-to-detect-cross-compiler.patch \
"
SRC_URI[md5sum] = "de67e0eca72474d6b1121037dafe1024"
SRC_URI[sha256sum] = "73043c35eb9636be0f4af6a240235c213f12a25feb1f04aeeac8cb7e30fcbdd0"