aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-01-16 16:16:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:45:44 +0000
commit14cb8fe36fcb2dc20830fb4ba63ed1302255b61b (patch)
tree8fd3181a55eeb4487d4632976d72523b744498a1 /meta/recipes-multimedia
parent8aafed5f4757550f2ff688e1b8981e5e8e6e3428 (diff)
downloadopenembedded-core-contrib-14cb8fe36fcb2dc20830fb4ba63ed1302255b61b.tar.gz
gstreamer1.0: make libunwind detection deterministic
Otherwise libunwind support will be based on the contents of the sysroot, which can cause problems. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0.inc1
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch24
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.2.bb1
3 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc b/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc
index 86c6f66a2f..72d7ce68d0 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc
@@ -24,6 +24,7 @@ PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
PACKAGECONFIG[tests] = "--enable-tests,--disable-tests"
PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
PACKAGECONFIG[gst-tracer-hooks] = "--enable-gst-tracer-hooks,--disable-gst-tracer-hooks,"
+PACKAGECONFIG[unwind] = "--with-unwind,--without-unwind,libunwind"
EXTRA_OECONF = " \
--disable-dependency-tracking \
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch
new file mode 100644
index 0000000000..e39e6cad09
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch
@@ -0,0 +1,24 @@
+Make the detection of libunwind deterministic.
+
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index ac88fb2..182c19a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -829,3 +828,0 @@ AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
+-dnl libunwind is optionally used by the leaks tracer
+-PKG_CHECK_MODULES(UNWIND, libunwind, HAVE_UNWIND=yes, HAVE_UNWIND=no)
+-
+@@ -839,3 +836,7 @@ AC_CHECK_FUNC(backtrace, [
+-if test "x$HAVE_UNWIND" = "xyes"; then
+- AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])
+-fi
++dnl libunwind is optionally used by the leaks tracer
++AC_ARG_WITH([unwind],[AS_HELP_STRING([--with-unwind],[use libunwind])],
++ [], [with_unwind=yes])
++AS_IF([test "$with_unwind" = yes],
++ [PKG_CHECK_MODULES(UNWIND, libunwind)
++ AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])]
++)
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.2.bb
index cc5c57f70b..4a01e8c731 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.2.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.2.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
SRC_URI = " \
http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
+ file://deterministic-unwind.patch \
"
SRC_URI[md5sum] = "0d289e5bcec6353e6540ddb75b7d371b"
SRC_URI[sha256sum] = "150e8e81febac94c161d8141cde78a38038a8f56e8ec549f353da54994278d65"