aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-02-05 06:05:08 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-07 22:47:07 +0000
commitf4a805702df691cbd2b80aa5f75d6adfb0f145eb (patch)
tree9307370c3ca8f028650a42e651166d74221e2c60 /meta/recipes-multimedia
parentd0a8313a03711ff881ad89b6cfc545f66a0bc018 (diff)
downloadopenembedded-core-contrib-f4a805702df691cbd2b80aa5f75d6adfb0f145eb.tar.gz
libpng: Security fix CVE-2015-8472
libpng: Buffer overflow vulnerabilities in png_get_PLTE/png_set_PLTE functions this patch fixes an incomplete patch in CVE-2015-8126 Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/libpng/libpng-1.6.17/CVE-2015-8472.patch29
-rw-r--r--meta/recipes-multimedia/libpng/libpng_1.6.17.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libpng/libpng-1.6.17/CVE-2015-8472.patch b/meta/recipes-multimedia/libpng/libpng-1.6.17/CVE-2015-8472.patch
new file mode 100644
index 0000000000..404f012b02
--- /dev/null
+++ b/meta/recipes-multimedia/libpng/libpng-1.6.17/CVE-2015-8472.patch
@@ -0,0 +1,29 @@
+From 9f2ad4928e47036cf1ac9b8fe45a491f15be2324 Mon Sep 17 00:00:00 2001
+From: Glenn Randers-Pehrson <glennrp at users.sourceforge.net>
+Date: Wed, 4 Nov 2015 23:47:42 -0600
+Subject: [PATCH] [libpng16] Fixed new bug with CRC error after reading an
+ over-length palette.
+
+Upstream-Status: Backport
+CVE: CVE-2015-8472
+
+https://github.com/glennrp/libpng/commit/9f2ad4928e47036cf1ac9b8fe45a491f15be2324
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ pngrutil.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: libpng-1.6.17/pngrutil.c
+===================================================================
+--- libpng-1.6.17.orig/pngrutil.c
++++ libpng-1.6.17/pngrutil.c
+@@ -973,7 +973,7 @@ png_handle_PLTE(png_structrp png_ptr, pn
+ if (png_ptr->color_type == PNG_COLOR_TYPE_PALETTE)
+ #endif
+ {
+- png_crc_finish(png_ptr, 0);
++ png_crc_finish(png_ptr, (int) length - num * 3);
+ }
+
+ #ifndef PNG_READ_OPT_PLTE_SUPPORTED
diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.17.bb b/meta/recipes-multimedia/libpng/libpng_1.6.17.bb
index 110c43daf1..cc288c7f98 100644
--- a/meta/recipes-multimedia/libpng/libpng_1.6.17.bb
+++ b/meta/recipes-multimedia/libpng/libpng_1.6.17.bb
@@ -15,6 +15,7 @@ SRC_URI += "\
file://CVE-2015-8126_2.patch \
file://CVE-2015-8126_3.patch \
file://CVE-2015-8126_4.patch \
+ file://CVE-2015-8472.patch \
"
SRC_URI[md5sum] = "430a9b76b78533235cd4b9b26ce75c7e"