aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
diff options
context:
space:
mode:
authorTanu Kaskinen <tanu.kaskinen@linux.intel.com>2015-07-17 12:22:18 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-20 10:39:01 +0100
commit780981b10dcd4201b8c74b9d33105f80c5801b38 (patch)
tree477d68bcf1a8cd6ba1c319964758afcef746c3e6 /meta/recipes-multimedia/pulseaudio/pulseaudio.inc
parent40ffba7a7f0f32f0c8073a457a393891a31f8555 (diff)
downloadopenembedded-core-contrib-780981b10dcd4201b8c74b9d33105f80c5801b38.tar.gz
openembedded-core-contrib-780981b10dcd4201b8c74b9d33105f80c5801b38.tar.bz2
openembedded-core-contrib-780981b10dcd4201b8c74b9d33105f80c5801b38.zip
pulseaudio: rdepend on modules referenced by start-pulseaudio-x11
pulseaudio-server contains /usr/bin/start-pulseaudio-x11 when X11 is enabled, and that script tries to load module-device-manager, module-x11-cork-request, module-x11-publish, and module-x11-xsmp. Therefore, pulseaudio-server should rdepend on those modules when X11 is enabled, otherwise the script won't work as intended. [YOCTO #8007] Signed-off-by: Tanu Kaskinen <tanu.kaskinen@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/pulseaudio/pulseaudio.inc')
-rw-r--r--meta/recipes-multimedia/pulseaudio/pulseaudio.inc12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/pulseaudio/pulseaudio.inc b/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
index b309d26079..1a9d33a7e8 100644
--- a/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
+++ b/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
@@ -160,5 +160,15 @@ RDEPENDS_pulseaudio-misc += "pulseaudio-module-cli-protocol-unix"
FILES_pulseaudio-module-gconf += "${libexecdir}/pulse/gconf-helper"
FILES_pulseaudio-module-alsa-card += "${datadir}/pulseaudio/alsa-mixer"
+# The console-kit module is good to have on X11 systems (it keeps PulseAudio
+# running for the duration of the user login session). The device-manager and
+# x11-* modules are referenced from the start-pulseaudio-x11 script, so those
+# modules must be installed when X11 is enabled.
RDEPENDS_pulseaudio-server += "\
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'pulseaudio-module-console-kit', '', d)}"
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '\
+ pulseaudio-module-console-kit \
+ pulseaudio-module-device-manager \
+ pulseaudio-module-x11-cork-request \
+ pulseaudio-module-x11-publish \
+ pulseaudio-module-x11-xsmp \
+ ', '', d)}"