aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/mpg123
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-02-27 14:02:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 11:17:22 +0000
commit0a1427bf9aeeda6bee2cc0af8da4ea5fd90aef6f (patch)
tree832a708208f36aa18b43b090f8963683f03986ee /meta/recipes-multimedia/mpg123
parent6db26339522a22c3e3c13287ea0c9daf40c7c15e (diff)
downloadopenembedded-core-contrib-0a1427bf9aeeda6bee2cc0af8da4ea5fd90aef6f.tar.gz
recipes: Make use of the new bb.utils.filter() function
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/mpg123')
-rw-r--r--meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb b/meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb
index f4c5c7cce8..e0a70380ea 100644
--- a/meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb
+++ b/meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb
@@ -20,7 +20,7 @@ inherit autotools pkgconfig
# The options should be mutually exclusive for configuration script.
# If both alsa and pulseaudio are specified (as in the default distro features)
# pulseaudio takes precedence.
-PACKAGECONFIG_ALSA = "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
+PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
@@ -33,13 +33,8 @@ PACKAGECONFIG[sdl] = ",,libsdl"
# Following are possible sound output modules:
# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi
-AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'alsa', 'alsa', '', d)}"
-AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'esd', 'esd', '', d)}"
-AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'jack', 'jack', '', d)}"
-AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'openal', 'openal', '', d)}"
-AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'portaudio', 'portaudio', '', d)}"
+AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}"
AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
-AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'sdl', 'sdl', '', d)}"
EXTRA_OECONF = " \
--enable-shared \