aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libsndfile
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-11 15:14:02 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:24 -0800
commit041fc758e250a70a19ee2019e82fd9ed7e3b7101 (patch)
treee2c6961cde91e31e927b8eee5048d4a7ba94b197 /meta/recipes-multimedia/libsndfile
parent48c8100cc161fcc932a92a92637304796c623f3d (diff)
downloadopenembedded-core-contrib-041fc758e250a70a19ee2019e82fd9ed7e3b7101.tar.gz
libsndfile: Upgrade to 1.0.23
Renamed and moved to recipes-multimedia Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/libsndfile')
-rw-r--r--meta/recipes-multimedia/libsndfile/libsndfile1/acincludefix.patch26
-rw-r--r--meta/recipes-multimedia/libsndfile/libsndfile1/add-cxx.patch18
-rw-r--r--meta/recipes-multimedia/libsndfile/libsndfile1_1.0.23.bb24
3 files changed, 68 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libsndfile/libsndfile1/acincludefix.patch b/meta/recipes-multimedia/libsndfile/libsndfile1/acincludefix.patch
new file mode 100644
index 0000000000..46a21c19be
--- /dev/null
+++ b/meta/recipes-multimedia/libsndfile/libsndfile1/acincludefix.patch
@@ -0,0 +1,26 @@
+Fix m4 quoting to avoid an infinite loop in m4 with recent autoconf/automake
+
+RP 1/2/10
+
+Index: libsndfile-1.0.17/acinclude.m4
+===================================================================
+--- libsndfile-1.0.17.orig/acinclude.m4 2010-02-01 14:53:35.517826746 +0000
++++ libsndfile-1.0.17/acinclude.m4 2010-02-01 14:53:51.409122706 +0000
+@@ -255,7 +255,7 @@
+
+ )
+ ]
+-
++[
+ if test $ac_cv_c_byte_order = big ; then
+ ac_cv_c_big_endian=1
+ ac_cv_c_little_endian=0
+@@ -272,7 +272,7 @@
+ AC_MSG_WARN([[*** src/config.h may need to be hand editied. ]])
+ AC_MSG_WARN([[*****************************************************************]])
+ fi
+-
++]
+ )# AC_C_FIND_ENDIAN
+
+
diff --git a/meta/recipes-multimedia/libsndfile/libsndfile1/add-cxx.patch b/meta/recipes-multimedia/libsndfile/libsndfile1/add-cxx.patch
new file mode 100644
index 0000000000..da0c4010e6
--- /dev/null
+++ b/meta/recipes-multimedia/libsndfile/libsndfile1/add-cxx.patch
@@ -0,0 +1,18 @@
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- libsndfile-1.0.17.orig/configure.ac
++++ libsndfile-1.0.17/configure.ac
+@@ -29,10 +29,11 @@ AC_LANG([C])
+ # to 0.
+
+ SHARED_VERSION_INFO="1:17:0"
+
+ AC_PROG_CC
++AC_PROG_CXX
+ AM_PROG_LIBTOOL
+
+ AC_CHECK_PROG(autogen, autogen, yes, no)
+
+ AC_PROG_INSTALL
diff --git a/meta/recipes-multimedia/libsndfile/libsndfile1_1.0.23.bb b/meta/recipes-multimedia/libsndfile/libsndfile1_1.0.23.bb
new file mode 100644
index 0000000000..c5a3983538
--- /dev/null
+++ b/meta/recipes-multimedia/libsndfile/libsndfile1_1.0.23.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "An audio format Conversion library"
+HOMEPAGE = "http://www.mega-nerd.com/libsndfile"
+AUTHOR = "Erik de Castro Lopo"
+DEPENDS = "sqlite3"
+SECTION = "libs/multimedia"
+LICENSE = "LGPLv2.1"
+PR = "r0"
+
+SRC_URI = "http://www.mega-nerd.com/libsndfile/files/libsndfile-${PV}.tar.gz \
+ file://acincludefix.patch;patch=1 \
+ file://add-cxx.patch;patch=1"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=e77fe93202736b47c07035910f47974a"
+
+S = "${WORKDIR}/libsndfile-${PV}"
+
+inherit autotools lib_package pkgconfig
+
+do_configure_prepend_arm() {
+ export ac_cv_sys_largefile_source=1
+ export ac_cv_sys_file_offset_bits=64
+ ac_cv_sizeof_off_t=8
+}
+