aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2016-11-02 17:39:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:23 +0000
commitc7cb0ce17dc2ec3999f26d594e755c8fb9609cee (patch)
tree2f6a09b460f9d4ba749405485701bfc3c293875f /meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb
parent053aac136cec74b0ac848337812546df847dc793 (diff)
downloadopenembedded-core-contrib-c7cb0ce17dc2ec3999f26d594e755c8fb9609cee.tar.gz
libsamplerate0: clean up dependencies
The flac dependency was completely bogus. Flac isn't used at all. FFTW is only used by tests, so we don't need to provide a packageconfig for that. ALSA is only used by example code that isn't part of the packaged files, so even if ALSA is enabled, it doesn't affect the build result. Nevertheless, I prefer to disable it explicitly to be extra sure. --disable-alsa resulted in a warning about an unsupported configure option, although by some magic it seemed to actually work as expected. A patch is added to get rid of that warning. Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb')
-rw-r--r--meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb b/meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb
index a24b8c7abc..5473bffca4 100644
--- a/meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb
+++ b/meta/recipes-multimedia/libsamplerate/libsamplerate0_0.1.9.bb
@@ -4,10 +4,12 @@ SECTION = "libs"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=336d6faf40fb600bafb0061f4052f1f4 \
file://src/samplerate.c;beginline=1;endline=7;md5=5b6982a8c2811c7312c13cccbf55f55e"
-DEPENDS = "flac libsndfile1"
+DEPENDS = "libsndfile1"
PR = "r1"
-SRC_URI = "http://www.mega-nerd.com/SRC/libsamplerate-${PV}.tar.gz"
+SRC_URI = "http://www.mega-nerd.com/SRC/libsamplerate-${PV}.tar.gz \
+ file://0001-configure.ac-improve-alsa-handling.patch \
+"
SRC_URI[md5sum] = "2b78ae9fe63b36b9fbb6267fad93f259"
SRC_URI[sha256sum] = "0a7eb168e2f21353fb6d84da152e4512126f7dc48ccb0be80578c565413444c1"
@@ -18,4 +20,7 @@ S = "${WORKDIR}/libsamplerate-${PV}"
inherit autotools pkgconfig
-PACKAGECONFIG[fftw] = ",--disable-fftw,fftw"
+# FFTW and ALSA are only used in tests and examples, so they don't affect
+# normal builds. It should be safe to ignore these, but explicitly disabling
+# them adds some extra certainty that builds are deterministic.
+EXTRA_OECONF = "--disable-fftw --disable-alsa"