aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-player_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-02-26 17:59:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-26 21:43:03 +0000
commit07e79c259dda660715fcdf802af66273209670ba (patch)
treead5a882315bccda1d79a1693cf68decd8b091b84 /meta/recipes-multimedia/gstreamer/gst-player_git.bb
parent49b21abf1020b2eefbbec98415c3d7de8827c993 (diff)
downloadopenembedded-core-contrib-07e79c259dda660715fcdf802af66273209670ba.tar.gz
gst-player: add
gst-player is a convenience library for handling media playback in GStreamer. It also has a sample application that can be used as a basic media player for testing. Patch in a file selector for use without a terminal and a desktop file so it appears in the desktop. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-player_git.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-player_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-player_git.bb b/meta/recipes-multimedia/gstreamer/gst-player_git.bb
new file mode 100644
index 0000000000..a7df526b82
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-player_git.bb
@@ -0,0 +1,31 @@
+SUMMARY="GStreamer playback helper library and examples"
+
+LICENSE = "LGPL-2.0+"
+LIC_FILES_CHKSUM = "file://lib/gst/player/gstplayer.c;beginline=1;endline=19;md5=03aeca9d8295f811817909075a15ff65"
+
+DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gtk+3"
+
+SRC_URI = "git://github.com/sdroege/gst-player.git \
+ file://filechooser.patch \
+ file://gst-player.desktop"
+
+SRCREV = "5386c5b984d40ef5434673ed62204e69aaf52645"
+
+S = "${WORKDIR}/git"
+
+inherit autotools gtk-doc lib_package pkgconfig
+
+do_configure_prepend() {
+ touch ${S}/ChangeLog
+}
+
+EXTRA_OECONF += "ac_cv_path_VALGRIND=no ac_cv_path_GDB=no"
+
+do_install_append() {
+ install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
+}
+
+FILES_${PN}-bin += "${datadir}/applications/*.desktop"
+
+RDEPENDS_${PN}-bin = "gstreamer1.0-plugins-base-playback"
+RRECOMMENDS_${PN}-bin = "gstreamer1.0-plugins-base-meta gstreamer1.0-plugins-good-meta gstreamer1.0-plugins-bad-meta gstreamer1.0-plugins-ugly-meta"