aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
diff options
context:
space:
mode:
authorYao Zhao <yao.zhao@windriver.com>2012-08-08 14:49:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-15 14:25:49 +0100
commita6384b2bd1d608506557ce151135edffa4cb5e0b (patch)
treebf2426a47b798dc80ec4d989caa5725d91889488 /meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
parentdec33ee2c8badb64b90ce8230f218c6898f3703c (diff)
downloadopenembedded-core-contrib-a6384b2bd1d608506557ce151135edffa4cb5e0b.tar.gz
gstreamer: gst-ffmpeg: fix build issues for libav
1.The included libav configure is not generated by autotools modify recipe to use correct toolchain wrapper with configure 2.add bzip2 dependency explicitly. or configure will detect whether libbz2 is installed, if bzip2 is triggered earlier then it will be detected, if not then won't 3.backport libav_e500mc.patch from upstream to patch configure to disable-altivec if it is e500mc. 4.move the GSTREAMER_DEBUG to libav's configure, it is not the option for the main configure. Signed-off-by: Yao Zhao <yao.zhao@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb b/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
index a166290cfc..efab2cf4af 100644
--- a/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.13.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://gst-libs/ext/libav/COPYING.LGPLv2.1;md5=e344c8fa836c3a41c4cbd79d7bd3a379 \
file://gst-libs/ext/libav/COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
HOMEPAGE = "http://www.gstreamer.net/"
-DEPENDS = "gstreamer gst-plugins-base zlib"
+DEPENDS = "gstreamer gst-plugins-base zlib bzip2"
inherit autotools pkgconfig
@@ -19,15 +19,25 @@ SRC_URI = "http://gstreamer.freedesktop.org/src/${BPN}/${BPN}-${PV}.tar.bz2 \
file://lower-rank.diff \
file://configure-fix.patch \
file://h264_qpel_mmx.patch \
+ file://libav_e500mc.patch \
"
SRC_URI[md5sum] = "7f5beacaf1312db2db30a026b36888c4"
SRC_URI[sha256sum] = "76fca05b08e00134e3cb92fa347507f42cbd48ddb08ed3343a912def187fbb62"
-PR = "r3"
+PR = "r4"
GSTREAMER_DEBUG ?= "--disable-debug"
-EXTRA_OECONF = "--with-ffmpeg-extra-configure=\"--target-os=linux\" ${GSTREAMER_DEBUG}"
+
+FFMPEG_EXTRA_CONFIGURE = "--with-ffmpeg-extra-configure"
+FFMPEG_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux \
+ --cc='${CC}' --as='${CC}' --ld='${CC}' --nm='${NM}' --ar='${AR}' \
+ --ranlib='${RANLIB}' \
+ ${GSTREAMER_DEBUG}"
+FFMPEG_EXTRA_CONFIGURE_COMMON = \
+'${FFMPEG_EXTRA_CONFIGURE}="${FFMPEG_EXTRA_CONFIGURE_COMMON_ARG}"'
+
+EXTRA_OECONF = "${FFMPEG_EXTRA_CONFIGURE_COMMON}"
# yasm not found, use --disable-yasm for a crippled build for libav
EXTRA_OECONF_append_x86-64 = " --disable-yasm "