summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-devtools_1.18.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-11-02 17:48:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:20:42 +0000
commitd375ad9f36f3c8be8f8d5fe26fbbf43e84bd17ed (patch)
treea0c865068248f55599c07cd9ca3175f41973e7d8 /meta/recipes-multimedia/gstreamer/gst-devtools_1.18.1.bb
parent5cafc3721cbe0193fb444adba4cc82a820f3f33f (diff)
downloadopenembedded-core-contrib-d375ad9f36f3c8be8f8d5fe26fbbf43e84bd17ed.tar.gz
gstreamer1.0: upgrade 1.18.0 -> 1.18.1
License-Update: COPYING replaces gpl2 with lgpl2.1, COPYING.LIB removed. This does not change the overall licensing situation as explained here: https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1422 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-devtools_1.18.1.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-devtools_1.18.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-devtools_1.18.1.bb b/meta/recipes-multimedia/gstreamer/gst-devtools_1.18.1.bb
new file mode 100644
index 0000000000..2e09ef9c25
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-devtools_1.18.1.bb
@@ -0,0 +1,42 @@
+SUMMARY = "Gstreamer validation tool"
+DESCRIPTION = "A Tool to test GStreamer components"
+HOMEPAGE = "https://gstreamer.freedesktop.org/documentation/gst-devtools/index.html"
+SECTION = "multimedia"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://validate/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+#S = "${WORKDIR}/gst-devtools-${PV}"
+
+SRC_URI = "https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-${PV}.tar.xz \
+ file://0001-connect-has-a-different-signature-on-musl.patch \
+ "
+
+SRC_URI[sha256sum] = "712212babd2238233d55beecfc0fe1ea8db18e8807ac6ab05a64505b2c7ab0df"
+
+DEPENDS = "json-glib glib-2.0 glib-2.0-native gstreamer1.0 gstreamer1.0-plugins-base"
+RRECOMMENDS_${PN} = "git"
+
+FILES_${PN} += "${datadir}/gstreamer-1.0/* ${libdir}/gst-validate-launcher/* ${libdir}/gstreamer-1.0/*"
+
+inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection
+
+# TODO: put this in a gettext.bbclass patch
+def gettext_oemeson(d):
+ if d.getVar('USE_NLS') == 'no':
+ return '-Dnls=disabled'
+ # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
+ if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
+ return '-Dnls=disabled'
+ return '-Dnls=enabled'
+
+EXTRA_OEMESON += " \
+ -Ddoc=disabled \
+ -Ddebug_viewer=disabled \
+ -Dtests=disabled \
+ -Dvalidate=enabled \
+ ${@gettext_oemeson(d)} \
+"
+
+GIR_MESON_ENABLE_FLAG = "enabled"
+GIR_MESON_DISABLE_FLAG = "disabled"