aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-24 12:33:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-15 10:00:28 +0100
commit2a39c8529332c4ea0f8edcac7cfdfb410ca3fb5b (patch)
tree0ffc665a7a5316523d2fd3d34f4871144f4c169b /meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
parentccc7a422b7b43f68a10ee6ec9aea7e6074a69630 (diff)
downloadopenembedded-core-contrib-2a39c8529332c4ea0f8edcac7cfdfb410ca3fb5b.tar.gz
alsa-tools: Update to 1.1.6
License-Update: FSF address updated in hdsploader/COPYING and ld10k1/COPYING.LIB Fix built with clang along the way Package python dependent tools into a separate package Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
new file mode 100644
index 0000000000..e065eec6b8
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
@@ -0,0 +1,55 @@
+SUMMARY = "Advanced tools for certain ALSA sound card drivers"
+HOMEPAGE = "http://www.alsa-project.org"
+BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
+SECTION = "console/utils"
+LICENSE = "GPLv2 & LGPLv2+"
+DEPENDS = "alsa-lib ncurses glib-2.0"
+
+LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://ld10k1/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7 \
+ "
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/${BP}.tar.bz2 \
+ file://autotools.patch \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'file://makefile_no_gtk.patch', d)} \
+ file://gitcompile_hdajacksensetest \
+ file://0002-Fix-clang-Wreserved-user-defined-literal-warnings.patch \
+ "
+
+SRC_URI[md5sum] = "5ca8c9437ae779997cd62fb2815fef19"
+SRC_URI[sha256sum] = "d69c4dc2fb641a974d9903e9eb78c94cb0c7ac6c45bae664f0c9d6c0a1593227"
+
+inherit autotools-brokensep pkgconfig
+
+CLEANBROKEN = "1"
+
+EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
+PACKAGECONFIG[gtk+] = ",,gtk+ gtk+3,"
+
+# configure.ac/.in doesn't exist so force copy
+AUTOTOOLS_COPYACLOCAL = "1"
+
+do_compile_prepend () {
+ #Automake dir is not correctly detected in cross compilation case
+ export AUTOMAKE_DIR="$(automake --print-libdir)"
+ export ACLOCAL_FLAGS="--system-acdir=${ACLOCALDIR}/ ${ACLOCALEXTRAPATH}"
+
+ cp ${WORKDIR}/gitcompile_hdajacksensetest ${S}/hdajacksensetest/gitcompile
+}
+
+do_install_append() {
+ sed -i -e "s|/usr/bin/python2|/usr/bin/env python2|g" ${D}${bindir}/hwmixvolume
+}
+
+PACKAGES =+ "${PN}-hwmixvolume"
+
+FILES_${PN}-hwmixvolume = "${bindir}/hwmixvolume"
+
+FILES_${PN} += "${datadir}/ld10k1 \
+ ${datadir}/icons/hicolor \
+ "
+
+RDEPENDS_${PN}-hwmixvolume += "python"
+