aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2017-11-27 18:39:31 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-09 14:36:57 +0000
commit00b73cbe8ae6d1dd6ba82f0ab5cd38c2d712deb7 (patch)
tree74dc8923d8c5bb7053c07c6b180228ebe58bd029 /meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
parent930f8873e0e180da7242f65bfd5c60f9d6c19424 (diff)
downloadopenembedded-core-contrib-00b73cbe8ae6d1dd6ba82f0ab5cd38c2d712deb7.tar.gz
alsa-lib: 1.1.4.1 -> 1.1.5
Changes: http://www.alsa-project.org/main/index.php/Changes_v1.1.4_v1.1.5 Dropped all patches. The poll.h patch is included in the release, and the wordexp patch is not needed any more, because the wordexp function is replaced by an internal reimplementation. It would still be possible to enable the use of wordexp with the --with-wordexp configure option. The option exists, because the internal reimplementation covers only part of what wordexp can do, so not using wordexp can in theory cause regressions. However, it seems that regressions are quite unlikely in practice. Here's some discussion about the topic: http://mailman.alsa-project.org/pipermail/alsa-devel/2017-July/122667.html Signed-off-by: Tanu Kaskinen <tanuk@iki.fi> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
new file mode 100644
index 0000000000..c5bf107e5e
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.1.5.bb
@@ -0,0 +1,40 @@
+SUMMARY = "ALSA sound library"
+HOMEPAGE = "http://www.alsa-project.org"
+BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
+SECTION = "libs/multimedia"
+LICENSE = "LGPLv2.1 & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
+ file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/${BP}.tar.bz2"
+SRC_URI[md5sum] = "a2b465c3a5265d8a57f3ff39c6c4fc29"
+SRC_URI[sha256sum] = "f4f68ad3c6da36b0b5241ac3c798a7a71e0e97d51f972e9f723b3f20a9650ae6"
+
+inherit autotools pkgconfig
+
+require alsa-fpu.inc
+EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
+
+EXTRA_OECONF += "--disable-python"
+
+PACKAGES =+ "alsa-server libasound alsa-conf alsa-doc"
+FILES_libasound = "${libdir}/libasound.so.*"
+FILES_alsa-server = "${bindir}/*"
+FILES_alsa-conf = "${datadir}/alsa/"
+
+RDEPENDS_libasound = "alsa-conf"
+
+# alsa-lib gets automatically added to alsa-lib-dev dependencies, but the
+# alsa-lib package doesn't exist. libasound is the real library package.
+RDEPENDS_${PN}-dev = "libasound"
+
+# upgrade path
+RPROVIDES_${PN}-dev = "alsa-dev"
+RREPLACES_${PN}-dev = "alsa-dev"
+RCONFLICTS_${PN}-dev = "alsa-dev"
+
+RPROVIDES_alsa-conf = "alsa-conf-base"
+RREPLACES_alsa-conf = "alsa-conf-base"
+RCONFLICTS_alsa-conf = "alsa-conf-base"