aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2014-08-29 20:06:32 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-31 23:39:10 +0100
commit736dc0abd22be122cac053e8934e8bfd5b82eec0 (patch)
tree2880e677666cc39831e37297be1acf5b8c1f1517 /meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch
parent7a8d88b73d35ac86198a1092c49b33c378416a03 (diff)
downloadopenembedded-core-contrib-736dc0abd22be122cac053e8934e8bfd5b82eec0.tar.gz
alsa-lib: upgrade to 1.0.28
Changelog: http://www.alsa-project.org/main/index.php/Changes_v1.0.27.2_v1.0.28 Update-iatomic.h-functions-definitions-for-mips.patch removed, integrated upstream. Check-if-wordexp-function-is-supported.patch updated. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch31
1 files changed, 16 insertions, 15 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch b/meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch
index 41b3c23a40..75a6eb8a3c 100644
--- a/meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch
+++ b/meta/recipes-multimedia/alsa/alsa-lib/Check-if-wordexp-function-is-supported.patch
@@ -1,6 +1,6 @@
-From 2555c5d62229cf269974f6ec6e4689ab97bbda42 Mon Sep 17 00:00:00 2001
+From e33357b59a10d44e9bec5d24100ce23ca300cc79 Mon Sep 17 00:00:00 2001
From: "Hong H. Pham" <hong.pham@windriver.com>
-Date: Tue, 26 Feb 2013 19:40:04 -0500
+Date: Fri, 29 Aug 2014 17:13:55 +0300
Subject: [PATCH] Check if wordexp function is supported
eglibc could be configured to build without wordexp, so it is not enough
@@ -8,24 +8,25 @@ to check if wordexp.h exists (the header file could be installed, but it's
possible that the wordexp() function is not supported). An additional
check if wordexp() is supported by the system C library is needed.
-Upstream-Status: Pending
+Upstream-Status: Inappropriate [configuration]
Signed-off-by: Hong H. Pham <hong.pham@windriver.com>
+Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
---
- configure.in | 5 ++++-
- src/userfile.c | 2 +-
+ configure.ac | 5 ++++-
+ src/userfile.c | 2 +-
2 files changed, 5 insertions(+), 2 deletions(-)
-diff --git a/configure.in b/configure.in
-index 4bcb0d6..ba1c2dd 100644
---- a/configure.in
-+++ b/configure.in
-@@ -333,7 +333,10 @@ arm*)
- esac
+diff --git a/configure.ac b/configure.ac
+index b8353a0..773b72f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -311,7 +311,10 @@ fi
+ AC_SUBST(ALSA_DEPLIBS)
- dnl Check for wordexp.h
--AC_CHECK_HEADERS([wordexp.h])
-+AC_CHECK_HEADERS([wordexp.h],
+ dnl Check for headers
+-AC_CHECK_HEADERS([wordexp.h endian.h sys/endian.h])
++AC_CHECK_HEADERS([wordexp.h endian.h sys/endian.h],
+ dnl Make sure wordexp is supported by the C library
+ AC_CHECK_FUNCS([wordexp])
+)
@@ -46,5 +47,5 @@ index 3a73836..b8ce809 100644
#include <assert.h>
int snd_user_file(const char *file, char **result)
--
-1.7.10.4
+1.9.1