summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-09-09 22:04:10 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-11 17:07:05 +0100
commitd7981babc55845914f20e7deb11b81aa2dbfcff3 (patch)
tree749d17c70189f005a11c2d605b2a1536117ddd3b /meta/recipes-kernel
parentc178a5609b2f3cca52532a8b6d6a5927cad386db (diff)
downloadopenembedded-core-contrib-d7981babc55845914f20e7deb11b81aa2dbfcff3.tar.gz
kernel-devsrc: account for HOSTCC and HOSTCXX
Since commit 740d87766cb87f75c477 [kernel.bbclass: Configuration for environment with HOSTCXX], both HOSTCC and HOSTCXX are pickedup by the kernel build system as triggers to reconfigure if changed. As with previous changes to devsrc, we replace the cross build variant, with what will be on target, so operations such as 'make scripts prepare' won't trigger a reconfiguration. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index a9c7be0f81..aa8e162f4f 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -261,6 +261,8 @@ do_install() {
if [ -e "$kerneldir/build/include/config/auto.conf.cmd" ]; then
sed -i 's/ifneq "$(CC)" ".*-linux-.*gcc.*$/ifneq "$(CC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
sed -i 's/ifneq "$(LD)" ".*-linux-.*ld.bfd.*$/ifneq "$(LD)" "ld"/' "$kerneldir/build/include/config/auto.conf.cmd"
+ sed -i 's/ifneq "$(HOSTCXX)" ".*$/ifneq "$(HOSTCXX)" "g++"/' "$kerneldir/build/include/config/auto.conf.cmd"
+ sed -i 's/ifneq "$(HOSTCC)" ".*$/ifneq "$(HOSTCC)" "gcc"/' "$kerneldir/build/include/config/auto.conf.cmd"
sed -i 's/ifneq "$(CC_VERSION_TEXT)".*\(gcc.*\)"/ifneq "$(CC_VERSION_TEXT)" "\1"/' "$kerneldir/build/include/config/auto.conf.cmd"
sed -i 's/ifneq "$(srctree)" ".*"/ifneq "$(srctree)" "."/' "$kerneldir/build/include/config/auto.conf.cmd"
# we don't build against the defconfig, so make sure it isn't the trigger for syncconfig