summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-09-02 10:33:03 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-03 09:43:59 +0100
commitccea217e6f8d8489e71b0801953542faf679d23d (patch)
tree4ffb41604e7744b0eedd021d4c853f218eee9047 /meta/recipes-kernel
parentbdd06f8ed58ed1c4983f8188e98f1a132da91e3d (diff)
downloadopenembedded-core-contrib-ccea217e6f8d8489e71b0801953542faf679d23d.tar.gz
linux-yocto/5.8: update to v5.8.5
Updating linux-yocto/5.8 to the latest korg -stable release that comprises the following commits: 9ece50d8a470 Linux 5.8.5 c05dea7c0f3f binfmt_flat: revert "binfmt_flat: don't offset the data start" 44f639d5aeda io_uring: fix missing ->mm on exit 3f4be7a7db9f netlink: fix state reallocation in policy export 1c0be9a99c9c ethtool: Don't omit the netlink reply if no features were changed 507d7ac63fad ethtool: Account for hw_features in netlink interface e53140320193 ethtool: Fix preserving of wanted feature bits in netlink interface da995e0a6dac net: ena: Make missed_tx stat incremental 3942262b7499 tipc: fix uninit skb->data in tipc_nl_compat_dumpit() 828fd2e892b0 tipc: call rcu_read_lock() in tipc_aead_encrypt_done() 22f2be57784e net/smc: Prevent kernel-infoleak in __smc_diag_dump() df805b956877 net: sctp: Fix negotiation of the number of data streams. 4c1fc05e5d6a net/sched: act_ct: Fix skb double-free in tcf_ct_handle_fragments() error flow 351366ffef2c net: qrtr: fix usage of idr in port assignment to socket c4c76ec584a7 net: nexthop: don't allow empty NHA_GROUP a75f8a60c415 net: Fix potential wrong skb->protocol in skb_vlan_untag() 3f13223bb0b1 gre6: Fix reception with IP6_TNL_F_RCV_DSCP_COPY Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb6
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.8.bb20
3 files changed, 15 insertions, 15 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb
index f956f04d53..a87cad962e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb
@@ -11,13 +11,13 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
+SRCREV_machine ?= "ded3e9afb3262feb367227c63da1f762f893b192"
SRCREV_meta ?= "0a4bef3856894e8bca3c74c97e7924ad262c0dc8"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.8;destsuffix=${KMETA}"
-LINUX_VERSION ?= "5.8.4"
+LINUX_VERSION ?= "5.8.5"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
index ae3b82b86a..3661072a48 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
@@ -6,7 +6,7 @@ KCONFIG_MODE = "--allnoconfig"
require recipes-kernel/linux/linux-yocto.inc
-LINUX_VERSION ?= "5.8.4"
+LINUX_VERSION ?= "5.8.5"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
@@ -15,8 +15,8 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine_qemuarm ?= "657076afb65e40e322bcc3b2bb8eeca590e20912"
-SRCREV_machine ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
+SRCREV_machine_qemuarm ?= "5bc60299c57b6dd6d88cd3196e1a3949a4365214"
+SRCREV_machine ?= "ded3e9afb3262feb367227c63da1f762f893b192"
SRCREV_meta ?= "0a4bef3856894e8bca3c74c97e7924ad262c0dc8"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.8.bb b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
index 0f162f87be..91a4873fc9 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
@@ -12,15 +12,15 @@ KBRANCH_qemux86 ?= "v5.8/standard/base"
KBRANCH_qemux86-64 ?= "v5.8/standard/base"
KBRANCH_qemumips64 ?= "v5.8/standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "a23a3757322d01974a65285aefcf7fdbbcde9aa8"
-SRCREV_machine_qemuarm64 ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
-SRCREV_machine_qemumips ?= "1f31484dac3aaf69f06a07d8869bd04d1d0377b7"
-SRCREV_machine_qemuppc ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
-SRCREV_machine_qemuriscv64 ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
-SRCREV_machine_qemux86 ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
-SRCREV_machine_qemux86-64 ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
-SRCREV_machine_qemumips64 ?= "768aed7c0609f38222ee7672981a9b60c943f4fb"
-SRCREV_machine ?= "6a095b50f83adc33b07bd1b3dbbcca8bec66849f"
+SRCREV_machine_qemuarm ?= "683da0bfdf000de0d65dc4a3c66bdc9906735144"
+SRCREV_machine_qemuarm64 ?= "ded3e9afb3262feb367227c63da1f762f893b192"
+SRCREV_machine_qemumips ?= "a86380b2bc78d8a40af8608569fe8d7f88f1bfd7"
+SRCREV_machine_qemuppc ?= "ded3e9afb3262feb367227c63da1f762f893b192"
+SRCREV_machine_qemuriscv64 ?= "ded3e9afb3262feb367227c63da1f762f893b192"
+SRCREV_machine_qemux86 ?= "ded3e9afb3262feb367227c63da1f762f893b192"
+SRCREV_machine_qemux86-64 ?= "ded3e9afb3262feb367227c63da1f762f893b192"
+SRCREV_machine_qemumips64 ?= "c0568a8edccef3a9bb29c2c4911b8200892c23f2"
+SRCREV_machine ?= "ded3e9afb3262feb367227c63da1f762f893b192"
SRCREV_meta ?= "0a4bef3856894e8bca3c74c97e7924ad262c0dc8"
# remap qemuarm to qemuarma15 for the 5.8 kernel
@@ -30,7 +30,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRA
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.8;destsuffix=${KMETA}"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
-LINUX_VERSION ?= "5.8.4"
+LINUX_VERSION ?= "5.8.5"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"