summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-08-24 15:00:39 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-25 01:00:20 +0100
commit0ebbcbefc8c1a6731b81b7f1aba695a3665a256e (patch)
treecca6f9a7791e6ca53c813eac59c45fafc3b909f5 /meta/recipes-kernel
parent74188412ae3019235151f3e606a470ff27c7ed63 (diff)
downloadopenembedded-core-contrib-0ebbcbefc8c1a6731b81b7f1aba695a3665a256e.tar.gz
linux-yocto-rt/5.8: fix lttng-modules build
Integrating the following commit(s) to linux-yocto-rt/5.8: commit baee1af811ec9bd3e64990543b7cc85e77c8f50c (HEAD -> master) Author: Bruce Ashfield <bruce.ashfield@gmail.com> Date: Sun Aug 23 22:50:30 2020 -0400 linux-yocto/rt: enable kprobes by default Traditionally kprobes and -rt haven't mixed well, but recent -rt kernels support kprobes without issues. lttng now requires kprobes to be enabled, or the following error is thrown: | build/tmp/work/qemux86_64-poky-linux/lttng-modules/2.12.2-r0/lttng-modules-2.12.2/wrapper/kallsyms.c:20:3: error: #error "LTTng-modules requires CONFIG_KPROBES on kernels >= 5.7.0" | 20 | # error "LTTng-modules requires CONFIG_KPROBES on kernels >= 5.7.0" | | ^~~~~ | make[3]: *** [build/tmp/work-shared/qemux86-64/kernel-source/scripts/Makefile.build:280: build/tmp/work/qemux86_64-poky-linux/lttng-modules/2.12.2-r0/lttng-modules-2.12.2/wrapper/kallsyms.o] Error 1 By including the kprobes fragment into the -rt kernel by default, we fix the issue. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.8.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb
index 7b5588f01f..ca791a3b14 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.8.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "5d66d1a67c8d654fa400f476daefbf2acd3a99f3"
-SRCREV_meta ?= "a53fa3813188b421c420b85b51ba95e6a6278689"
+SRCREV_meta ?= "2f9b296099dc534d1c9909f34b1090d8d2280c9b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.8;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
index 8e7272b54e..ed07f6d9d7 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.8.bb
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine_qemuarm ?= "01ca9ab2d6cb0de4425d9dfca99dff30653083d9"
SRCREV_machine ?= "5d66d1a67c8d654fa400f476daefbf2acd3a99f3"
-SRCREV_meta ?= "a53fa3813188b421c420b85b51ba95e6a6278689"
+SRCREV_meta ?= "2f9b296099dc534d1c9909f34b1090d8d2280c9b"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.8.bb b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
index e6e1189802..b10554af87 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.8.bb
@@ -21,7 +21,7 @@ SRCREV_machine_qemux86 ?= "5d66d1a67c8d654fa400f476daefbf2acd3a99f3"
SRCREV_machine_qemux86-64 ?= "5d66d1a67c8d654fa400f476daefbf2acd3a99f3"
SRCREV_machine_qemumips64 ?= "3109e6f363109f0dd4bd6a8647f639e445c533f2"
SRCREV_machine ?= "5d66d1a67c8d654fa400f476daefbf2acd3a99f3"
-SRCREV_meta ?= "a53fa3813188b421c420b85b51ba95e6a6278689"
+SRCREV_meta ?= "2f9b296099dc534d1c9909f34b1090d8d2280c9b"
# remap qemuarm to qemuarma15 for the 5.8 kernel
# KMACHINE_qemuarm ?= "qemuarma15"