summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-12 23:41:23 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-16 22:21:31 +0000
commit103316d50d4947b3c3500eb5cbc4845702a62d22 (patch)
treebab78276d5bc337e062b74c2803b0c0c36b9c41f /meta/recipes-kernel
parent40de75663cfe37c543362022c8e454adade7066b (diff)
downloadopenembedded-core-contrib-103316d50d4947b3c3500eb5cbc4845702a62d22.tar.gz
perf: fix build for v5.5+
In kernel 5.5+ there are python3 scripts that explicitly use /usr/bin/python3 as the interpreter. That will find the host python and produce undefined results. We add that interpreter path to our substitutions to ensure that our sysroot variant is used. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 5f0ba7c180..840f3008b5 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -241,6 +241,7 @@ do_configure_prepend () {
sed -i 's,/usr/bin/python,/usr/bin/env python3,' "${s}"
sed -i 's,/usr/bin/python2,/usr/bin/env python3,' "${s}"
sed -i 's,/usr/bin/env python2,/usr/bin/env python3,' "${s}"
+ sed -i 's,/usr/bin/python3,/usr/bin/env python3,' "${s}"
done
# unistd.h can be out of sync between libc-headers and the captured version in the perf source