aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-05-24 14:56:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 11:43:10 +0100
commit7950b1ed077eaecff1523221c297158aa54b7ecf (patch)
treeed8d847b1bded2a1494cd79331bde1b84247645c /meta/recipes-kernel
parent5ff707e15c68d77c371b43a970e62302f7492545 (diff)
downloadopenembedded-core-contrib-7950b1ed077eaecff1523221c297158aa54b7ecf.tar.gz
perf: fix build with kernel older than 4.8
* perf is failing to build for me since this oe-core commit: commit 9b38c824961fc9dce51bda95c25dac91a69fc64f Author: Hongxu Jia <hongxu.jia@windriver.com> Date: Tue Apr 24 11:33:47 2018 +0800 perf: make a copy of kernel source to perf workdir the problem is that perf sources in kernel older than 4.8 (in my case 4.4) are depending on the "global" include headers outside tools directory, e.g. swab.h in: kernel-source/tools$ git grep swab.h perf/MANIFEST:include/linux/swab.h perf/MANIFEST:include/uapi/linux/swab.h perf/util/include/asm/byteorder.h:#include "../../../../include/uapi/linux/swab.h" this was resolved in 4.8 with: commit 7e3f36411342a54f1981fa97b43550b8406a3d69 Author: Arnaldo Carvalho de Melo <acme@redhat.com> Date: Mon Jul 18 17:42:16 2016 -0300 perf tools: Remove tools/perf/util/include/asm/byteorder.h Not used anymore. This also stops include linux/swab.h directly from the kernel sources, remove that reference from the MANIFEST. and few more changes to make tools/include more complete and standalone: tools/include in 4.15: asm asm-generic linux tools trace uapi tools/include in 4.4: asm asm-generic linux tools but copying the include header even for kernels which don't really need it doesn't add big overhead, so just copy include to perf sources for all kernels. (From OE-Core rev: 19fb2d11a8bb3c6dfdd5edc1b9155d642dc0f5e0) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index fb4e3ac668..51f5597eb9 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -98,6 +98,7 @@ EXTRA_OEMAKE += "\
"
PERF_SRC ?= "Makefile \
+ include \
tools/arch \
tools/build \
tools/include \