aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-08-05 22:37:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-08 13:38:53 +0100
commit0d240f56ea0128c1228f7cfe1471039a7b602a88 (patch)
treeebb3359516af91838e54d3e2f895c011c85fac5b /meta/recipes-kernel
parenta2f09cb149121ed2fddd7d602b286711ce1acecf (diff)
downloadopenembedded-core-contrib-0d240f56ea0128c1228f7cfe1471039a7b602a88.tar.gz
lttng-ust: Update to 0.15
This address [YOCTO #1005] which was waiting for upstream updates from the lttng and GDB teams. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch50
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_0.15.bb (renamed from meta/recipes-kernel/lttng/lttng-ust_0.12.bb)13
2 files changed, 7 insertions, 56 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch b/meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch
deleted file mode 100644
index f4ea196c71..0000000000
--- a/meta/recipes-kernel/lttng/lttng-ust/uclibc-sched_getcpu.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-uClibc does not have sched_getcpu() implemented. So we create a wrapper
-to getcpu syscall when compiling for uclibc.
-
-So far execinfo.h does not exist on uclibc but it turns out to be that
-this header is not needed even in eglibc case so it can be removed
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Accepted
-
-Index: ust-0.12/libust/tracer.h
-===================================================================
---- ust-0.12.orig/libust/tracer.h
-+++ ust-0.12/libust/tracer.h
-@@ -342,14 +342,22 @@ static __inline__ void ltt_write_trace_h
- header->start_freq = trace->start_freq;
- header->freq_scale = trace->freq_scale;
- }
--
-+#ifdef __UCLIBC__
-+#define sched_getcpu(cpu, node, cache) syscall(__NR_getcpu, cpu, node, cache)
-+#endif
- #ifndef UST_VALGRIND
-
- static __inline__ int ust_get_cpu(void)
- {
- int cpu;
-
-+#ifdef __UCLIBC__
-+ int c, s;
-+ s = syscall(__NR_getcpu, &c, NULL, NULL);
-+ cpu = (s == -1) ? s : c;
-+#else
- cpu = sched_getcpu();
-+#endif
- if (likely(cpu >= 0))
- return cpu;
- /*
-Index: ust-0.12/libustcomm/ustcomm.c
-===================================================================
---- ust-0.12.orig/libustcomm/ustcomm.c
-+++ ust-0.12/libustcomm/ustcomm.c
-@@ -31,7 +31,6 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <execinfo.h>
-
- #include "ustcomm.h"
- #include "usterr.h"
diff --git a/meta/recipes-kernel/lttng/lttng-ust_0.12.bb b/meta/recipes-kernel/lttng/lttng-ust_0.15.bb
index 5fca949f39..915e619c8c 100644
--- a/meta/recipes-kernel/lttng/lttng-ust_0.12.bb
+++ b/meta/recipes-kernel/lttng/lttng-ust_0.15.bb
@@ -10,19 +10,20 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e647752e045a8c45b6f583771bd561ef \
DEPENDS = "liburcu"
-PR = "r0"
+PR = "r2"
-SRC_URI = "http://lttng.org/files/ust/releases/ust-${PV}.tar.gz \
- file://uclibc-sched_getcpu.patch \
- "
+SRC_URI = "http://lttng.org/files/ust/releases/ust-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "86c71486a70695dc0b2171ad16fc82b3"
+SRC_URI[sha256sum] = "7ff7ecdc051c0649d5fd21b5ceff4895ca95dc34f14cdc04e50de13cfd1903c5"
-SRC_URI[md5sum] = "fae6e324a56016658c5b83ec14ba0043"
-SRC_URI[sha256sum] = "215b05f47d0c9e3a2934926a7d14fa9c67025db917c3a1f641df40b08314ab0c"
S = "${WORKDIR}/ust-${PV}"
inherit autotools
+#EXTRA_OECONF = "ac_cv_lib_urcu_bp_synchronize_rcu_bp=no"
+
# Due to liburcu not building on MIPS currently this recipe needs to
# be limited also.
# So here let us first suppport x86/arm/powerpc platforms now.