aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-04 14:49:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-04 23:35:25 +0000
commit94ee0470af875501ef76ceff2c7e239f34a11495 (patch)
tree9297b822b5f3c3c802f153ca017a1e48d91b1320 /meta/recipes-kernel
parent6708665b4d72e1c56021a73f99e02657c5600c88 (diff)
downloadopenembedded-core-contrib-94ee0470af875501ef76ceff2c7e239f34a11495.tar.gz
lttng-tools: Fix ptest installed la files
The ptest .la files are just getting copied into new directories, we need to relocate them and update the paths within. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_git.bb b/meta/recipes-kernel/lttng/lttng-tools_git.bb
index e68e7f3e8a..26312033ce 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_git.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_git.bb
@@ -69,6 +69,11 @@ do_install_ptest () {
-i $i
done
+ # Update libdir references in copied .la files
+ for i in `find ${D}${PTEST_PATH} -type f -name *.la`; do
+ sed -i -e 's#${S}/tests/#${STAGING_DIR}${PTEST_PATH}#g' $i
+ done
+
sed -e "s:src/bin:bin:g" -e "s:lt-::g" \
-i ${D}${PTEST_PATH}/tests/utils/utils.sh
sed -e "s:ini_config:\.libs\/ini_config:" \