aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-01-18 10:55:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-26 23:15:47 +0000
commitf8b00a49bc6e57aafbfc48ee76d392f4003c5bf7 (patch)
treed50827f27911b17866488759ce556e9cfb74280c /meta/recipes-kernel
parenta316b06f4eba9f9996e5f6a7cf122e9cafd31710 (diff)
downloadopenembedded-core-contrib-f8b00a49bc6e57aafbfc48ee76d392f4003c5bf7.tar.gz
linux-yocto/4.12: drm & mips fixes
Integrating the following bug fixes (mainline backports): d572780c455f Mips kernel warining:resolve some warning when compiling arch/mips/math-emu/cp1emu.c f79ac7203257 drm/tilcdc: Precalculate total frametime in tilcdc_crtc_set_mode() Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.12.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
index 78a24e0b27..1698e59ebb 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "1b4229c4ef99843401ec2f522b63c9a64ed219a4"
+SRCREV_machine ?= "6cfdf8e22b784e169254ee6e306ea08bcac5be2b"
SRCREV_meta ?= "358b2bb4d2bc8e790f69ea1778d7d16184b1ae34"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
index 97b90daa1d..30b4fd134c 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.12.18"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "e0256c639caf7fb1b977cf34c5e15c86dd643c85"
+SRCREV_machine ?= "d572780c455fcd055baf1e6ff6fd4ea2dece9df2"
SRCREV_meta ?= "358b2bb4d2bc8e790f69ea1778d7d16184b1ae34"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.12.bb b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
index c27801a080..f60e484558 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "e984c8a333b87570a3d28384f0473884134e9535"
-SRCREV_machine_qemuarm64 ?= "e0256c639caf7fb1b977cf34c5e15c86dd643c85"
-SRCREV_machine_qemumips ?= "a81c25e8409d8a1dfdb353a03553a57c25e50755"
-SRCREV_machine_qemuppc ?= "e0256c639caf7fb1b977cf34c5e15c86dd643c85"
-SRCREV_machine_qemux86 ?= "e0256c639caf7fb1b977cf34c5e15c86dd643c85"
-SRCREV_machine_qemux86-64 ?= "e0256c639caf7fb1b977cf34c5e15c86dd643c85"
-SRCREV_machine_qemumips64 ?= "a39650a75fbd15424c51963d893e7806d9fdbe8b"
-SRCREV_machine ?= "e0256c639caf7fb1b977cf34c5e15c86dd643c85"
+SRCREV_machine_qemuarm ?= "8dff23316c2c8a291541c94f615205a0e6cc547c"
+SRCREV_machine_qemuarm64 ?= "d572780c455fcd055baf1e6ff6fd4ea2dece9df2"
+SRCREV_machine_qemumips ?= "fbe79a19f0f14e46a8ac62de9ebb5691a5084e00"
+SRCREV_machine_qemuppc ?= "d572780c455fcd055baf1e6ff6fd4ea2dece9df2"
+SRCREV_machine_qemux86 ?= "d572780c455fcd055baf1e6ff6fd4ea2dece9df2"
+SRCREV_machine_qemux86-64 ?= "d572780c455fcd055baf1e6ff6fd4ea2dece9df2"
+SRCREV_machine_qemumips64 ?= "e6d567b4c476ec7edfc6721e6912daa5fa672add"
+SRCREV_machine ?= "d572780c455fcd055baf1e6ff6fd4ea2dece9df2"
SRCREV_meta ?= "358b2bb4d2bc8e790f69ea1778d7d16184b1ae34"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \