aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2018-07-04 03:17:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-07 11:05:02 +0100
commit6f0079a6c3cc8926423cff3a927a78dcecede90d (patch)
treefa8140a2eead64b3076d4e4de1069ab95ca99a66 /meta/recipes-kernel
parentd1737f2dabac5e338061863c78a91b4c115365c7 (diff)
downloadopenembedded-core-contrib-6f0079a6c3cc8926423cff3a927a78dcecede90d.tar.gz
lttng-tools: Allow reconnect to relayd
If relayd is started after connection attempt from consumerd it will leave the session in disconnected state and causes the following inconvenience. This is covered by an upstream feature, see https://bugs.lttng.org/issues/883. Before it's done, this patches allows users to reconnect to relayd. root@localhost:~# lttng enable-event --userspace --all Error: Events: UST create channel failed (channel channel0, session trace_session) root@localhost:~# lttng-relayd -b Warning: No tracing group detected root@localhost:~# lttng enable-event --userspace --all Error: Events: UST create channel failed (channel channel0, session trace_session) Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools/0001-Allow-multiple-attempts-to-connect-to-relayd.patch43
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools/0001-Allow-multiple-attempts-to-connect-to-relayd.patch b/meta/recipes-kernel/lttng/lttng-tools/0001-Allow-multiple-attempts-to-connect-to-relayd.patch
new file mode 100644
index 0000000000..62a0978592
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-tools/0001-Allow-multiple-attempts-to-connect-to-relayd.patch
@@ -0,0 +1,43 @@
+From 70eff899104b86bae02862927c76caaef5de5d3c Mon Sep 17 00:00:00 2001
+From: Mikael Beckius <mikael.beckius@windriver.com>
+Date: Thu, 7 May 2015 16:14:25 +0200
+Subject: [PATCH] Allow multiple attempts to connect to relayd.
+
+It is unclear why a session needs to be made
+unusable after a failure to connect to relayd
+since a check for a relayd connection is
+always made before a session can be configured.
+
+The behaviour was introduced in:
+d9078d0c000d04d49c599a72c1a725026b636ec0
+
+Signed-off-by: Mikael Beckius <mikael.beckius@windriver.com>
+[ The context has moved, adjust the hunk accordingly ]
+Signed-off-by: He Zhe <zhe.he@windriver.com>
+Upstream-Status: Pending
+---
+ src/bin/lttng-sessiond/cmd.c | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/src/bin/lttng-sessiond/cmd.c b/src/bin/lttng-sessiond/cmd.c
+index 73b4ce3..36f62ee 100644
+--- a/src/bin/lttng-sessiond/cmd.c
++++ b/src/bin/lttng-sessiond/cmd.c
+@@ -689,14 +689,6 @@ close_sock:
+ free(rsock);
+
+ error:
+- if (ret != LTTNG_OK) {
+- /*
+- * The consumer output for this session should not be used anymore
+- * since the relayd connection failed thus making any tracing or/and
+- * streaming not usable.
+- */
+- consumer->enabled = 0;
+- }
+ return ret;
+ }
+
+--
+1.7.9.5
+
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb b/meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb
index 93626dd4b5..e4969c3080 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.9.5.bb
@@ -30,6 +30,7 @@ PACKAGECONFIG_remove_riscv64 = "lttng-ust"
SRC_URI = "https://lttng.org/files/lttng-tools/lttng-tools-${PV}.tar.bz2 \
file://x32.patch \
file://run-ptest \
+ file://0001-Allow-multiple-attempts-to-connect-to-relayd.patch \
"
SRC_URI[md5sum] = "051224eb991aee07f8721ff1877d0b96"