aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-11-30 19:42:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:39:12 +0000
commit00e354910b9ff751acb937e6ca2ef9f66a49bac7 (patch)
tree514eb5efe44df9191107d607449d4c4df3a0d5a8 /meta/recipes-kernel
parentc148c3639de35d9ebd52a71cf9cc62c7cce25bd4 (diff)
downloadopenembedded-core-contrib-00e354910b9ff751acb937e6ca2ef9f66a49bac7.tar.gz
lttng-tools: fix for x32
(From OE-Core rev: af0203f1543e444d4c9397c6b400ba627baf9574) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools/x32.patch16
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_git.bb1
2 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools/x32.patch b/meta/recipes-kernel/lttng/lttng-tools/x32.patch
new file mode 100644
index 0000000000..b1bb8e4930
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-tools/x32.patch
@@ -0,0 +1,16 @@
+Fix build for x32
+
+Upstream-Status: Pending
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+
+--- lttng-tools-2.6.0/src/bin/lttng/utils.c~ 2015-01-26 18:17:15.000000000 +0100
++++ lttng-tools-2.6.0/src/bin/lttng/utils.c 2015-07-30 19:45:25.632045712 +0200
+@@ -130,7 +130,7 @@
+ #define HAS_FLS_U32
+ #endif
+
+-#if defined(__x86_64)
++#if defined(__x86_64) && !defined(__ILP32__)
+ static inline
+ unsigned int fls_u64(uint64_t x)
+ {
diff --git a/meta/recipes-kernel/lttng/lttng-tools_git.bb b/meta/recipes-kernel/lttng/lttng-tools_git.bb
index 0d2bd005e4..29fd75b217 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_git.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_git.bb
@@ -31,6 +31,7 @@ PACKAGECONFIG_remove_libc-musl = "lttng-ust"
SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.8 \
file://0001-Fix-error.h-common-error.h.patch \
+ file://x32.patch \
file://run-ptest"
S = "${WORKDIR}/git"