aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-05-27 12:18:35 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-30 15:56:48 +0100
commitb746223787a0195c3a4d16523003c62ec0ac8451 (patch)
tree2c8a615c25c6b015c7f22ef83c5baf59449dc774 /meta/recipes-kernel
parente3aa87a5d3a7cbe6f2c835273991a388101b0cde (diff)
downloadopenembedded-core-contrib-b746223787a0195c3a4d16523003c62ec0ac8451.tar.gz
linux-yocto/4.1: fix musb compilation error
We had a partial musb change merged into the 4.1 tree, which resulted in: | kernel-source/drivers/usb/musb/musb_dsps.c: In function 'dsps_create_musb_pdev': | kernel-source/drivers/usb/musb/musb_dsps.c:750:8: error: 'struct musb_hdrc_config' has no member named 'maximum_speed' | config->maximum_speed = usb_get_maximum_speed(&parent->dev); | ^~ By backporting commit: 9b7537642cb6a [usb: musb: set the controller speed based on the config setting] We get our missing structure field, and we can once again build musb. [YOCTO: #9680] Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 1d4c404ef0..24cc0ac077 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "320892013ad33ab41f530ad321939aec07d09d22"
+SRCREV_machine ?= "e22280e8c2905d96c7cc5917df202b6ed904d042"
SRCREV_meta ?= "4b4199bd24f206d459061bb0a920d009429d5ed3"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 9757c4d020..bf7d6c5959 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.24"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_machine ?= "403eda4633e9037fb715d0d1e8ae847b2bd0651a"
SRCREV_meta ?= "4b4199bd24f206d459061bb0a920d009429d5ed3"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index e0d288b6e9..c325bc59c6 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "d11c336b38ab0d4e55eb683aca5ca9c6b6cd8b42"
-SRCREV_machine_qemuarm64 ?= "ecc983477682203619da0e456fa4a8689ac41097"
-SRCREV_machine_qemumips ?= "f8e363f638b283738369155b4a9990b5d0f902a7"
-SRCREV_machine_qemuppc ?= "ecc983477682203619da0e456fa4a8689ac41097"
-SRCREV_machine_qemux86 ?= "ecc983477682203619da0e456fa4a8689ac41097"
-SRCREV_machine_qemux86-64 ?= "ecc983477682203619da0e456fa4a8689ac41097"
-SRCREV_machine_qemumips64 ?= "1db47ec6c39071b29f82a040b9b9a81584f50461"
-SRCREV_machine ?= "ecc983477682203619da0e456fa4a8689ac41097"
+SRCREV_machine_qemuarm ?= "cadb80aa4bcee282f1b0798ef35ad8b96ec44931"
+SRCREV_machine_qemuarm64 ?= "403eda4633e9037fb715d0d1e8ae847b2bd0651a"
+SRCREV_machine_qemumips ?= "737eda6388a529d0937e9d91daa3644b11f322dc"
+SRCREV_machine_qemuppc ?= "403eda4633e9037fb715d0d1e8ae847b2bd0651a"
+SRCREV_machine_qemux86 ?= "403eda4633e9037fb715d0d1e8ae847b2bd0651a"
+SRCREV_machine_qemux86-64 ?= "403eda4633e9037fb715d0d1e8ae847b2bd0651a"
+SRCREV_machine_qemumips64 ?= "f276d128428b031521d766bfbfe84f9f9f992930"
+SRCREV_machine ?= "403eda4633e9037fb715d0d1e8ae847b2bd0651a"
SRCREV_meta ?= "4b4199bd24f206d459061bb0a920d009429d5ed3"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \