aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorMatthieu Crapet <Matthieu.Crapet@ingenico.com>2014-03-19 16:46:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-21 12:05:29 +0000
commit5df4e63e747028c3ce89f1f9ae01a766ae34dc3d (patch)
treeeda9e6b0092c1513bb7145e43c6394825546245c /meta/recipes-kernel
parent3eb2435a7c7c8108cb73945d5003a9fc7455befd (diff)
downloadopenembedded-core-contrib-5df4e63e747028c3ce89f1f9ae01a766ae34dc3d.tar.gz
linux-dummy: provide kernel-modules (empty) package
Like it is done in kernel.bbclass Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-dummy.bb18
1 files changed, 12 insertions, 6 deletions
diff --git a/meta/recipes-kernel/linux/linux-dummy.bb b/meta/recipes-kernel/linux/linux-dummy.bb
index bab1ac1c0c..5d29f5cc12 100644
--- a/meta/recipes-kernel/linux/linux-dummy.bb
+++ b/meta/recipes-kernel/linux/linux-dummy.bb
@@ -1,16 +1,22 @@
-SECTION = "kernel"
SUMMARY = "Dummy Linux kernel"
DESCRIPTION = "Dummy Linux kernel, to be selected as the preferred \
provider for virtual/kernel to satisfy dependencies for situations \
where you wish to build the kernel externally from the build system."
-LICENSE = "GPLv2"
+SECTION = "kernel"
+LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
PROVIDES += "virtual/kernel"
PACKAGES_DYNAMIC += "^kernel-module-.*"
PACKAGES_DYNAMIC += "^kernel-image-.*"
+PACKAGES_DYNAMIC += "^kernel-firmware-.*"
+
+PACKAGES += "kernel-modules"
+FILES_kernel-modules = ""
+ALLOW_EMPTY_kernel-modules = "1"
+DESCRIPTION_kernel-modules = "Kernel modules meta package"
#COMPATIBLE_MACHINE = "your_machine"
@@ -20,19 +26,19 @@ SRC_URI = "file://COPYING.GPL"
S = "${WORKDIR}"
do_configure() {
- :
+ :
}
do_compile () {
- :
+ :
}
do_install() {
- :
+ :
}
do_bundle_initramfs() {
- :
+ :
}
do_deploy() {