aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-27 18:01:44 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-28 14:00:21 +0000
commit006b8a7808a58713af16c326dc37d07765334b12 (patch)
tree7fb385008db2170db8de182851c26e1156944de1 /meta/recipes-kernel
parent9d796611afc42bea5ad9cab47ba4fb5ac0cb5ddd (diff)
downloadopenembedded-core-contrib-006b8a7808a58713af16c326dc37d07765334b12.tar.gz
autotools-brokensep: Mark recipes with broken separate build dir support
This patch goes through the OE-Core recipes and marks those which use autotools but don't support a separate build directory (${S} != ${B}). A new class, autotools-brokensep is used for this purpose. This doesn't introduce any change in behaviour in its own right. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/dtc/dtc.inc2
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools.inc2
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.3.1.bb2
-rw-r--r--meta/recipes-kernel/oprofile/oprofile.inc2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-kernel/dtc/dtc.inc b/meta/recipes-kernel/dtc/dtc.inc
index de375d7a7d..3eca25fe41 100644
--- a/meta/recipes-kernel/dtc/dtc.inc
+++ b/meta/recipes-kernel/dtc/dtc.inc
@@ -4,7 +4,7 @@ SECTION = "bootloader"
LICENSE = "GPLv2 | BSD"
DEPENDS = "flex-native bison-native"
-inherit autotools
+inherit autotools-brokensep
SRC_URI = "git://www.jdl.com/software/dtc.git \
file://make_install.patch \
diff --git a/meta/recipes-kernel/kexec/kexec-tools.inc b/meta/recipes-kernel/kexec/kexec-tools.inc
index 5a9c515689..50b448caed 100644
--- a/meta/recipes-kernel/kexec/kexec-tools.inc
+++ b/meta/recipes-kernel/kexec/kexec-tools.inc
@@ -10,7 +10,7 @@ DEPENDS = "zlib xz"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/kexec/kexec-tools-${PV}.tar.gz"
-inherit autotools
+inherit autotools-brokensep
COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*|mips.*)-(linux|freebsd.*)'
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.3.1.bb b/meta/recipes-kernel/lttng/lttng-tools_2.3.1.bb
index e0ce564567..ee59a4645b 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.3.1.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.3.1.bb
@@ -22,7 +22,7 @@ SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.3 \
S = "${WORKDIR}/git"
-inherit autotools ptest
+inherit autotools-brokensep ptest
export KERNELDIR="${STAGING_KERNEL_DIR}"
diff --git a/meta/recipes-kernel/oprofile/oprofile.inc b/meta/recipes-kernel/oprofile/oprofile.inc
index b09aaf8c5f..678d40ef7d 100644
--- a/meta/recipes-kernel/oprofile/oprofile.inc
+++ b/meta/recipes-kernel/oprofile/oprofile.inc
@@ -26,7 +26,7 @@ SRC_URI = "file://opstart.patch \
file://oprofile-root.patch \
file://acinclude.m4"
-inherit autotools
+inherit autotools-brokensep
EXTRA_OECONF = "--with-kernel=${STAGING_KERNEL_DIR} --without-x"
do_configure () {