aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-09-17 00:46:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-01 07:40:22 +0100
commit48c168334bb60937653ab782026948d139603f8e (patch)
tree5ad7254c70043e4317183bfd2efb08f1affe2b71 /meta/recipes-kernel
parent8eb5bd93614db57654d9d3fcc2edcf6f26f148a6 (diff)
downloadopenembedded-core-contrib-48c168334bb60937653ab782026948d139603f8e.tar.gz
meta: fix build with gettext 0.16.1
The gettext 0.16.1 doesn't install any m4 files to sysroot, please see the following commit: commit 9e10db5bdfe77c0ef2aff2f1cf89958b62c294a1 Author: Christopher Larson <kergoth@gmail.com> Date: Mon Mar 17 18:10:54 2014 +0000 gettext-0.16.1: kill target m4 macros from sysroot This is aim for using gettext-native's macros(gettext-native-0.19.4), but when we set: PREFERRED_VERSION_gettext = "0.16.1" And build the recipes like pcmanfm, we would get errors when do_configure: configure:5164: error: possibly undefined macro: AM_NLS This is because autotools_copy_aclocals doesn't copy the native macros for target unless they're direct dependencies. Add gettext-native to DEPENDS will fix the problem. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb2
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
index eb3b78b906..cc3477bc7b 100644
--- a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://git.yoctoproject.org/oprofileui \
file://init \
file://oprofileui-server.service "
-DEPENDS += "intltool-native"
+DEPENDS += "intltool-native gettext-native"
EXTRA_OECONF += "--disable-client --enable-server"
diff --git a/meta/recipes-kernel/oprofile/oprofileui_git.bb b/meta/recipes-kernel/oprofile/oprofileui_git.bb
index 8fad099664..86f3d8e50e 100644
--- a/meta/recipes-kernel/oprofile/oprofileui_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui_git.bb
@@ -1,6 +1,6 @@
require oprofileui.inc
-DEPENDS += "gtk+ libglade libxml2 avahi-ui gconf"
+DEPENDS += "gtk+ libglade libxml2 avahi-ui gconf gettext-native"
inherit distro_features_check
ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"