aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/sysprof/sysprof_git.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2015-11-11 11:35:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 08:07:53 +0000
commit191a1817c9dce90f3094bc98d6e0f5ab02f8a5c7 (patch)
tree6b3626221f971bf782df4e957d8a68cbcbaf5232 /meta/recipes-kernel/sysprof/sysprof_git.bb
parent35c5ab8f34400000129078e1a5246232b20fd265 (diff)
downloadopenembedded-core-contrib-191a1817c9dce90f3094bc98d6e0f5ab02f8a5c7.tar.gz
sysprof: use packageconfig for the gui
This makes the gtk dependencies optional. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/sysprof/sysprof_git.bb')
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-kernel/sysprof/sysprof_git.bb b/meta/recipes-kernel/sysprof/sysprof_git.bb
index 7d87efe7db..84c6aad39e 100644
--- a/meta/recipes-kernel/sysprof/sysprof_git.bb
+++ b/meta/recipes-kernel/sysprof/sysprof_git.bb
@@ -2,13 +2,14 @@ SUMMARY = "System-wide Performance Profiler for Linux"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-DEPENDS = "gtk+ libglade"
+DEPENDS = "glib-2.0"
SRCREV = "cd44ee6644c3641507fb53b8a2a69137f2971219"
PV = "1.2.0+git${SRCPV}"
SRC_URI = "git://git.gnome.org/sysprof \
file://define-NT_GNU_BUILD_ID.patch \
+ file://gui-argument.patch \
"
SRC_URI_append_arm = " file://rmb-arm.patch"
@@ -19,8 +20,10 @@ SRC_URI_append_mips64n32 = " file://rmb-mips.patch"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig distro_features_check
-ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+inherit autotools pkgconfig
+
+PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK2DISTROFEATURES}', 'gui', '', d)}"
+PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,gtk+ gdk-pixbuf pango libglade"
# We do not yet work for aarch64.
#