aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-14 16:07:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-16 12:11:25 +0000
commit7763b318e8c5f117aabe57e451879734ac2b81e4 (patch)
treed2aa6e49ceaaa326926a35471c030ef7818b6d42 /meta/recipes-kernel/powertop/powertop_2.8.bb
parent219d74d9df6a4a819d03091f35205a5634b268c7 (diff)
downloadopenembedded-core-contrib-7763b318e8c5f117aabe57e451879734ac2b81e4.tar.gz
powertop: update to 2.8
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.8.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.8.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.8.bb b/meta/recipes-kernel/powertop/powertop_2.8.bb
new file mode 100644
index 0000000000..a466067562
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.8.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Power usage tool"
+DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
+HOMEPAGE = "http://01.org/powertop/"
+BUGTRACKER = "http://bugzilla.lesswatts.org/"
+DEPENDS = "ncurses libnl pciutils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+
+SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "c55fedb69203e480801b18bd7b886241"
+SRC_URI[sha256sum] = "a87b563f73106babfa3e74dcf92f252938c061e309ace20a361358bbfa579c5a"
+
+UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
+
+inherit autotools gettext pkgconfig
+
+# we need to explicitly link with libintl in uClibc systems
+EXTRA_LDFLAGS ?= ""
+EXTRA_LDFLAGS_libc-uclibc = "-lintl"
+LDFLAGS += "${EXTRA_LDFLAGS}"
+
+# we do not want libncursesw if we can
+do_configure_prepend() {
+ # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
+ sed -i -e "s/ncursesw//g" ${S}/configure.ac
+ mkdir -p ${B}/src/tuning/
+}
+
+inherit update-alternatives
+ALTERNATIVE_${PN} = "powertop"
+ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
+ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
+ALTERNATIVE_PRIORITY = "100"