summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-07-04 11:13:55 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-04 22:51:46 +0100
commitb24e73fb34049061ea03a6f2b6a54cdbee7b406b (patch)
tree8e208caab8e11f950a43802b5d930cb5392c3f1d /meta/recipes-kernel/perf
parentdea3c7ee2a413f7dc5f13ec006592084f7fb266c (diff)
downloadopenembedded-core-contrib-b24e73fb34049061ea03a6f2b6a54cdbee7b406b.tar.gz
perf: fix reproducibility in 5.19+
kernels with upstream commit 630af16eee495f583db5202c3613d1b191f10694 [perf tools: Use Python devtools for version autodetection rather than runtime], or -stable backports of that commmit, evade our substitutions for reproducibility. We add a second sed expression to ensure that our definition of python is used, as we have the proper environement setup and don't need the full path of python, which eventually will be captured by the perf binaries. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf')
-rw-r--r--meta/recipes-kernel/perf/perf.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index adefc44eaa..603d3f9eee 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -228,6 +228,12 @@ do_configure:prepend () {
sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO))),g' \
${S}/tools/perf/Makefile.config
+ # likewise with this substitution. Kernels with commit 18f2967418d031a39
+ # [perf tools: Use Python devtools for version autodetection rather than runtime]
+ # need this substitution for reproducibility.
+ sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO))),$(notdir $(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO)))),g' \
+ ${S}/tools/perf/Makefile.config
+
# The following line:
# srcdir_SQ = $(patsubst %tools/perf,tools/perf,$(subst ','\'',$(srcdir))),
# Captures the full src path of perf, which of course makes it not