aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf
diff options
context:
space:
mode:
authorMartin Donnelly <martin.donnelly@ge.com>2016-02-22 19:32:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-26 17:16:20 +0000
commitf4f5573ba4f46acc5917526be761e241051d7fa8 (patch)
tree6b7b88bc3fb138cf3a4e897325dd8b869232f86e /meta/recipes-kernel/perf
parent7a95c2cb6715bed9d6904ef351fd7a793cbadb00 (diff)
downloadopenembedded-core-contrib-f4f5573ba4f46acc5917526be761e241051d7fa8.tar.gz
perf: add sysroot handling to subcmd
v4.5-rc1 of the kernel splits the subcommand related files from perf into a new library, this patch adds the modification of the Makefile to preserve the --sysroot option as for the other perf related Makefiles. (From OE-Core rev: e46eae34ac71d28aa92feed369c2d92248ed3e19) Signed-off-by: Martin Donnelly <martin.donnelly@ge.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf')
-rw-r--r--meta/recipes-kernel/perf/perf.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 33acb42712..8b86290201 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -164,6 +164,10 @@ do_configure_prepend () {
sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
fi
+ if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
+ sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
+ sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
+ fi
if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
fi