aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-18 23:58:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 11:54:19 +0000
commitdeb99cefe8be7fa63972edadf69f92d361b9a7c5 (patch)
tree5ebb33928fac125dad66cf45323ef2d9327c80ce /meta/recipes-kernel/perf
parent643ac87145eba5dc105377041bc3deb163b62926 (diff)
downloadopenembedded-core-contrib-deb99cefe8be7fa63972edadf69f92d361b9a7c5.tar.gz
perf: make PKGV match kernel version
Have perf grab and use the kernel version it's built from for PKGV, rather than the default perf recipe version, so the final packages get the kernel version instead of the default 1.0, which represents a backwards value from the previous recipe. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf')
-rw-r--r--meta/recipes-kernel/perf/perf.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 3c499224c7..182dd25d6e 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -32,7 +32,7 @@ RDEPENDS_${PN} += "elfutils bash ${SCRIPTING_RDEPENDS}"
PROVIDES = "virtual/perf"
-inherit kernel-arch pythonnative
+inherit linux-kernel-base kernel-arch pythonnative
# needed for building the tools/perf Python bindings
inherit python-dir
@@ -104,6 +104,10 @@ do_configure_prepend () {
sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile
}
+python do_package_prepend() {
+ bb.data.setVar('PKGV', '${@get_kernelversion('${S}').split("-")[0]}', d)
+}
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILES_${PN} += "${libexecdir}/perf-core"