summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-23 11:09:03 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-24 21:44:43 +0000
commitd7888b6d7fd1a1930013f3d4e31a2522038cdc62 (patch)
tree731b42c983d4fbfdc4ceb88db2ea434bb9288034 /meta/recipes-kernel/perf/perf.bb
parent79603557a1db051675e1eb2a79cf3a792fe87c01 (diff)
downloadopenembedded-core-contrib-d7888b6d7fd1a1930013f3d4e31a2522038cdc62.tar.gz
perf: fix python scripts QA errors
Two QA warnings were being generated from perf, due to the location of python scripts changing in the kernel build: WARNING: perf-1.0-r9 do_package_qa: QA Issue: /usr/libexec/perf-core/scripts/python/call-graph-from-postgresql.py contained in package perf-python requires /usr/bin/python2, but no providers found in RDEPENDS_perf-python? [file-rdeps] WARNING: QA Issue: /usr/libexec/perf-core/tests/attr.py_perf contained in package perf requires /usr/bin/python, but no providers found in its RDEPENDS [file-rdeps] By adding libexec dir to both the tests and scripts packaging, we get the appropriate RDEPENDS on the packages that actually contain the python scripts (without making perf-core depend on python). We also tweak any python scripts to use '/usr/bin/env python', rather than a version specific python, since it won't be provided and generate a QA error. [YOCTO #8991] Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 8b86290201..e9c5c0c9f3 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -183,6 +183,11 @@ do_configure_prepend () {
sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
fi
+
+ # use /usr/bin/env instead of version specific python
+ for s in `find ${S}/tools/perf/scripts/python/ -name '*.py'`; do
+ sed -i 's,/usr/bin/python2,/usr/bin/env python,' "${s}"
+ done
}
python do_package_prepend() {
@@ -205,8 +210,9 @@ RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent"
FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
-FILES_${PN}-tests = "${libdir}/perf/perf-core/tests"
+FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
FILES_${PN}-python = "${libdir}/python*/site-packages ${libdir}/perf/perf-core/scripts/python"
+FILES_${PN}-python += "${libexecdir}/perf-core/scripts/python/*"
FILES_${PN}-perl = "${libdir}/perf/perf-core/scripts/perl"