aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:39 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commit3063126e2c8ec72e900a48f7048aaf9662606792 (patch)
tree1535805e4a122156ac3416699deeac7cf28adbd9 /meta/recipes-kernel/oprofile/oprofileui-server_git.bb
parente6755e3351ccf1116c06b9608728630505908ce4 (diff)
downloadopenembedded-core-contrib-3063126e2c8ec72e900a48f7048aaf9662606792.tar.gz
oprofileui-server: move initscript from qemu-config
The qemu-config initscript was only starting oprofile-server, so move it to the oprofileui-server recipe. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofileui-server_git.bb')
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
index b9f6a811e5..e75923f2a3 100644
--- a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -6,8 +6,19 @@ PR = "r0"
S = "${WORKDIR}/git"
-SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git"
+SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git \
+ file://init"
EXTRA_OECONF += "--disable-client --enable-server"
RDEPENDS_${PN} = "oprofile"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/oprofileui-server
+}
+
+INITSCRIPT_NAME = "oprofileui-server"
+INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."
+
+inherit update-rc.d