aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile/oprofile/opstart.patch
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-01-04 17:29:54 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-07 14:30:38 +0000
commite8150e3941a471bf7e6d375595c15d54b809b15c (patch)
treebaf34f21efab105972fa93b9418b7d461bd65a48 /meta/recipes-kernel/oprofile/oprofile/opstart.patch
parent771a8851966d256b40f49fcd4352ea2c704fd985 (diff)
downloadopenembedded-core-contrib-e8150e3941a471bf7e6d375595c15d54b809b15c.tar.gz
oprofile: updated to 0.9.8
Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/oprofile/oprofile/opstart.patch')
-rw-r--r--meta/recipes-kernel/oprofile/oprofile/opstart.patch29
1 files changed, 15 insertions, 14 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofile/opstart.patch b/meta/recipes-kernel/oprofile/oprofile/opstart.patch
index c588deb337..0b181b1048 100644
--- a/meta/recipes-kernel/oprofile/oprofile/opstart.patch
+++ b/meta/recipes-kernel/oprofile/oprofile/opstart.patch
@@ -1,17 +1,18 @@
-Upstream-Status: Pending
-
-Index: oprofile/utils/Makefile.am
-===================================================================
---- oprofile.orig/utils/Makefile.am 2005-03-31 18:20:41.000000000 +0100
-+++ oprofile/utils/Makefile.am 2008-07-02 15:14:07.000000000 +0100
-@@ -3,8 +3,15 @@
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+index d34b060..dff15f9 100644
+--- oprofile.orig/utils/Makefile.am
++++ oprofile/utils/Makefile.am
+@@ -7,7 +7,7 @@ AM_LDFLAGS = @OP_LDFLAGS@
LIBS=@POPT_LIBS@ @LIBERTY_LIBS@
--bin_PROGRAMS = ophelp
-+bin_PROGRAMS = ophelp opstart
+-bin_PROGRAMS = ophelp op-check-perfevents
++bin_PROGRAMS = ophelp op-check-perfevents opstart
dist_bin_SCRIPTS = opcontrol
+ op_check_perfevents_SOURCES = op_perf_events_checker.c
+@@ -15,3 +15,10 @@ op_check_perfevents_CPPFLAGS = ${AM_CFLAGS} @PERF_EVENT_FLAGS@
+
ophelp_SOURCES = ophelp.c
ophelp_LDADD = ../libop/libop.a ../libutil/libutil.a
+
@@ -19,8 +20,8 @@ Index: oprofile/utils/Makefile.am
+
+install-exec-local:
+ cd $(DESTDIR)/$(bindir) && \
-+ rm -f opstop && \
-+ $(LN_S) opstart opstop
++ rm -f opstop && \
++ $(LN_S) opstart opstop
Index: oprofile/utils/opstart.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
@@ -136,10 +137,10 @@ Index: oprofile/utils/opstart.c
+ return 0;
+}
+
-Index: oprofile/configure.in
+Index: oprofile/configure.ac
===================================================================
---- oprofile.orig/configure.in 2008-07-02 15:13:58.000000000 +0100
-+++ oprofile/configure.in 2008-07-02 15:17:37.000000000 +0100
+--- oprofile.orig/configure.ac 2008-07-02 15:13:58.000000000 +0100
++++ oprofile/configure.ac 2008-07-02 15:17:37.000000000 +0100
@@ -16,6 +16,7 @@
AM_CONFIG_HEADER(config.h)