aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng
diff options
context:
space:
mode:
authorNathan Lynch <nathan_lynch@mentor.com>2015-06-15 13:37:24 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-23 11:38:12 +0100
commitcc6f6f96b668f7ef3db0f83c7d3585d81c569d31 (patch)
tree78b4f67ab02e7ace9d63842457beef243e641b7d /meta/recipes-kernel/lttng
parent9f5792088315ab42f77fe1a1af7d2225e7ad5418 (diff)
downloadopenembedded-core-contrib-cc6f6f96b668f7ef3db0f83c7d3585d81c569d31.tar.gz
lttng-modules: drop makefile patch
The lttng-modules Makefile allows us to specify the kernel we're building against via the KERNELDIR variable on the build command line. Use that and drop the patch (which tends to need updating whenever the upstream Makefile changes). Signed-off-by: Nathan Lynch <nathan_lynch@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/lttng')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch71
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb6
2 files changed, 2 insertions, 75 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch b/meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
deleted file mode 100644
index ccc6c54f81..0000000000
--- a/meta/recipes-kernel/lttng/lttng-modules/lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-lttng-modules: replace KERNELDIR with KERNEL_SRC
-
-Since lttng-modules uses the default way of module.bbclass to
-build and install lttng-modules, we do this replacement for
-it as-is.
-
-Signed-off-by: Zumeng Chen <zumeng.chen@windriver.com>
-[sgw - rebased for 2.6.1]
-Signed-off-by: Saul wold <sgw@linux.intel.com>
-
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -68,19 +68,19 @@ obj-m += lib/
- endif # CONFIG_TRACEPOINTS
-
- else # KERNELRELEASE
-- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
-- PWD := $(shell pwd)
-- CFLAGS = $(EXTCFLAGS)
--
-+ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
-+ PWD := $(shell pwd)
-+ CFLAGS = $(EXTCFLAGS)
-+
- default:
-- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
-+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
-
- modules_install:
-- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
-+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
-
- clean:
-- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
-+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
-
- %.i: %.c
-- LTTNG_KERNELDIR=$(KERNELDIR) $(MAKE) -C $(KERNELDIR) M=$(PWD) $@
-+ LTTNG_KERNELDIR=$(KERNEL_SRC) $(MAKE) -C $(KERNEL_SRC) M=$(PWD) $@
- endif # KERNELRELEASE
-Index: git/probes/Makefile
-===================================================================
---- git.orig/probes/Makefile
-+++ git/probes/Makefile
-@@ -267,18 +267,18 @@ endif
- endif
-
- else
-- KERNELDIR ?= /lib/modules/$(shell uname -r)/build
-+ KERNEL_SRC ?= /lib/modules/$(shell uname -r)/build
- PWD := $(shell pwd)
- CFLAGS = $(EXTCFLAGS)
-
- default:
-- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules
-+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules
-
- modules_install:
-- $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
-+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) modules_install
- /sbin/depmod -a
-
- clean:
-- $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
-+ $(MAKE) -C $(KERNEL_SRC) M=$(PWD) clean
-
- endif
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb
index be09a82f82..5bde7ec213 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.6.1.bb
@@ -12,13 +12,11 @@ SRCREV = "62080b2248fd8ec4111ffc379d0bc5eaf0a5c16d"
COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|arm).*-linux'
-SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.6 \
- file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch \
- "
+SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.6"
export INSTALL_MOD_DIR="kernel/lttng-modules"
-export KERNEL_SRC="${STAGING_KERNEL_DIR}"
+EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
S = "${WORKDIR}/git"