aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-12-11 15:32:56 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-12 23:42:55 +0000
commitb3d6872bf169a13e572638e3809c50a868246616 (patch)
treeefe123dd970a1f53cc5195eeb765512fc52d9c0c /meta/recipes-kernel/lttng
parent2c11bdd5cacbd642ebd8efdc504ec513579a1e71 (diff)
downloadopenembedded-core-contrib-b3d6872bf169a13e572638e3809c50a868246616.tar.gz
lttng-tools: Revert wrong enforcement of Python 3.0 use
The code has support and checks for Python 2 and Python 3 however during the development of 2.7 release a requirement for Python 3 was included. The Python 3 is required for runtime tests to run however those are not in use now so we can just disable the enforcement for now. This reverts the commit restoring the Python 2 support. (From OE-Core rev: 8807f4fd8a9ccdcdec016d87fd18fd0717f35dca) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools/Revert-Build-look-for-python-3.0-when-building-pytho.patch30
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_git.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools/Revert-Build-look-for-python-3.0-when-building-pytho.patch b/meta/recipes-kernel/lttng/lttng-tools/Revert-Build-look-for-python-3.0-when-building-pytho.patch
new file mode 100644
index 0000000000..d05c04c662
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-tools/Revert-Build-look-for-python-3.0-when-building-pytho.patch
@@ -0,0 +1,30 @@
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Fri, 4 Dec 2015 16:11:41 +0000
+Subject: [PATCH] Revert "Build: look for python >= 3.0 when building python bindings"
+Organization: O.S. Systems Software LTDA.
+
+This reverts commit 227703a2ceada3c104edd56756d48455ca4c271a.
+
+Upstream-Status: Pending
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4dee4b4..6608bcd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -339,7 +339,7 @@ AM_CONDITIONAL([PYTHON_BINDING], [test "x${enable_python_binding:-yes}" = xyes])
+
+ if test "x${enable_python_binding:-yes}" = xyes; then
+ AX_PKG_SWIG($swig_version, [], [ AC_MSG_ERROR([SWIG $swig_version or newer is needed]) ])
+- AM_PATH_PYTHON([3.0])
++ AM_PATH_PYTHON
+
+ AC_ARG_VAR([PYTHON_INCLUDE], [Include flags for python, bypassing python-config])
+ AC_ARG_VAR([PYTHON_CONFIG], [Path to python-config])
+--
+2.1.4
+
diff --git a/meta/recipes-kernel/lttng/lttng-tools_git.bb b/meta/recipes-kernel/lttng/lttng-tools_git.bb
index b124b953e6..82a0840ae8 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_git.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_git.bb
@@ -26,6 +26,7 @@ PACKAGECONFIG[lttng-ust] = "--enable-lttng-ust, --disable-lttng-ust, lttng-ust"
PACKAGECONFIG[kmod] = "--enable-kmod, --disable-kmod, kmod"
SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.7 \
+ file://Revert-Build-look-for-python-3.0-when-building-pytho.patch \
file://stop-using-SIGUNUSED.patch \
file://runtest-2.4.0.patch \
file://run-ptest"