aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-04 14:49:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-04 23:39:03 +0000
commit8ad11fc80baab50f22b04513b65762f80e646a16 (patch)
tree871b0fd122da32f9255f8afe07283a12d716b29a /meta/recipes-kernel/lttng
parent66ed16b27d2c1a8141fabff4925faf26d0b124c0 (diff)
downloadopenembedded-core-contrib-8ad11fc80baab50f22b04513b65762f80e646a16.tar.gz
lttng-tools: Fix ptest installed la files
The ptest .la files are just getting copied into new directories, we need to relocate them and update the paths within. (From OE-Core rev: 94ee0470af875501ef76ceff2c7e239f34a11495) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_git.bb b/meta/recipes-kernel/lttng/lttng-tools_git.bb
index e68e7f3e8a..26312033ce 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_git.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_git.bb
@@ -69,6 +69,11 @@ do_install_ptest () {
-i $i
done
+ # Update libdir references in copied .la files
+ for i in `find ${D}${PTEST_PATH} -type f -name *.la`; do
+ sed -i -e 's#${S}/tests/#${STAGING_DIR}${PTEST_PATH}#g' $i
+ done
+
sed -e "s:src/bin:bin:g" -e "s:lt-::g" \
-i ${D}${PTEST_PATH}/tests/utils/utils.sh
sed -e "s:ini_config:\.libs\/ini_config:" \