aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
diff options
context:
space:
mode:
authorNathan Lynch <nathan_lynch@mentor.com>2017-01-16 12:51:43 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:45:44 +0000
commita40bb2b7991adf5ef7121a45461747226c04bac1 (patch)
tree6ea69529fcbf13087f53f1832fa8de0fbdccd0d5 /meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
parent54d9fb2664d16a561f9e9232a53b60810678f9bf (diff)
downloadopenembedded-core-contrib-a40bb2b7991adf5ef7121a45461747226c04bac1.tar.gz
lttng-ust: upgrade to 2.9.0
buildhistory-diff says: /usr/lib/liblttng-ust-python-agent.so.0 was removed /usr/lib/liblttng-ust-python-agent.so.0.0.0 was removed This is because prior versions of lttng-ust unconditionally built the Python agent libraries; this was fixed upstream in 21ddb8e ("Only build python lib when agent is enabled"). Switch to using release tarballs. Signed-off-by: Nathan Lynch <nathan_lynch@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb b/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
new file mode 100644
index 0000000000..9cdefddf16
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.9.0.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
+DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
+HOMEPAGE = "http://lttng.org/ust"
+BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
+
+LICENSE = "LGPLv2.1+ & MIT & GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
+ file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
+ file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
+
+inherit autotools lib_package manpages
+
+DEPENDS = "liburcu util-linux"
+RDEPENDS_${PN}-bin = "python3-core"
+
+# For backwards compatibility after rename
+RPROVIDES_${PN} = "lttng2-ust"
+RREPLACES_${PN} = "lttng2-ust"
+RCONFLICTS_${PN} = "lttng2-ust"
+
+PE = "2"
+
+SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
+ file://lttng-ust-doc-examples-disable.patch \
+ "
+SRC_URI[md5sum] = "77f3378ba37a36801420bce87b702e9c"
+SRC_URI[sha256sum] = "4d541a863f42dfc685ca05024027a442c70d03594c154a43e62bc109b1ea5daf"
+
+PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
+
+do_install_append() {
+ # Patch python tools to use Python 3; they should be source compatible, but
+ # still refer to Python 2 in the shebang
+ sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
+}