aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-08-20 22:58:15 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-11 22:15:51 +0100
commit68f353d8a82a3b345e6e635258a606bf1c3991fb (patch)
tree271f53cfacb107865160c745db5e41077c0ac8ff /meta/recipes-kernel/linux
parent0a8c61d2351de7536c817242b0844e36dfe8b334 (diff)
downloadopenembedded-core-contrib-68f353d8a82a3b345e6e635258a606bf1c3991fb.tar.gz
linux-yocto/4.1: fix fsl-ls10xx sdhci
mmc: sdhci: fix two compile errors | CC drivers/mmc/host/sdhci.o | drivers/mmc/host/sdhci.c: In function 'sdhci_execute_tuning': | drivers/mmc/host/sdhci.c:1990:4: error: implicit | declaration of function 'sdhci_do_reset' | [-Werror=implicit-function-declaration] | sdhci_do_reset(host, SDHCI_RESET_CMD); | ^ | drivers/mmc/host/sdhci.c:2006:7: error: 'struct | mmc_command' has no member named 'busy_timeout' | cmd.busy_timeout = 50; | ^ In function sdhci_execute_tuning, replace sdhci_do_reset with sdhci_reset, replace busy_timeout with cmd_timeout_ms. Commit a629a90ba0 adds eMMC DDR mode support for t2080qds and modified some data structures and function name. Later commit a2080cc280 just backport upstream commit 61e53bd004 without aligning the current source tree thus cause these build errors. Fix them. Signed-off-by: Zhang Xiao <xiao.zhang@windriver.com> (From OE-Core rev: 538d2f0857f09ca86026d5771ea7c3fb74c0f857) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 4d40fd1b02..c12b403652 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "798e2cbf3dec954f37cb84463bc0b0a95cb54c8f"
+SRCREV_machine ?= "091d8c17b1ba75344ed88a909ead563139de68b3"
SRCREV_meta ?= "9f9c9a66ef3452343586adf150137967e955d71a"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 4f2f647975..44e6816063 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.42"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "e2bea2e96fcbbbb9b1efc3bc7505ac42e39bb5c0"
+SRCREV_machine ?= "f905fdd5da150ea809f847f00f3476220606c0ff"
SRCREV_meta ?= "9f9c9a66ef3452343586adf150137967e955d71a"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index b5a3cc8a9f..4e85a3eacf 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "f100a3d840596ac0dc47416336f34d8bf7b5ffa8"
-SRCREV_machine_qemuarm64 ?= "e2bea2e96fcbbbb9b1efc3bc7505ac42e39bb5c0"
-SRCREV_machine_qemumips ?= "4005321dfa890df693c12e902e48fd0dde88fee7"
-SRCREV_machine_qemuppc ?= "1e29490accfb0547e3a854ac6ec9a6754cd47204"
-SRCREV_machine_qemux86 ?= "e2bea2e96fcbbbb9b1efc3bc7505ac42e39bb5c0"
-SRCREV_machine_qemux86-64 ?= "e2bea2e96fcbbbb9b1efc3bc7505ac42e39bb5c0"
-SRCREV_machine_qemumips64 ?= "87c0f4d5bec646565e493d39bf57c3500151ed68"
-SRCREV_machine ?= "e2bea2e96fcbbbb9b1efc3bc7505ac42e39bb5c0"
+SRCREV_machine_qemuarm ?= "b7334672abf08f9dc9e277969e9266785580fa80"
+SRCREV_machine_qemuarm64 ?= "f905fdd5da150ea809f847f00f3476220606c0ff"
+SRCREV_machine_qemumips ?= "664fb3764bc804bfc9fd8ff582b374299e1fc016"
+SRCREV_machine_qemuppc ?= "7392e713c9eb1c67e9e6f8f2d14cae44467c1fbe"
+SRCREV_machine_qemux86 ?= "f905fdd5da150ea809f847f00f3476220606c0ff"
+SRCREV_machine_qemux86-64 ?= "f905fdd5da150ea809f847f00f3476220606c0ff"
+SRCREV_machine_qemumips64 ?= "85e973a2366e2a42d5082f5cd57852f8086502f4"
+SRCREV_machine ?= "f905fdd5da150ea809f847f00f3476220606c0ff"
SRCREV_meta ?= "9f9c9a66ef3452343586adf150137967e955d71a"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \