aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-04-13 12:12:10 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-14 10:58:28 +0100
commit7f13ab68e53aa2b12cea391e8d82808ce75c31df (patch)
tree5079c7d7f1235574563f2d8aa783214e780eae44 /meta/recipes-kernel/linux
parentec13eb0b19ee1d433329af0dd88ac5b31b13c1af (diff)
downloadopenembedded-core-contrib-7f13ab68e53aa2b12cea391e8d82808ce75c31df.tar.gz
linux-yocto/4.1: mainline SPI backports
Backporting SPI changes for the Broxton and Apollo lake: 91f62d4a0a31 spi: pxa2xx: derive struct chip_data from struct drv_data a9ed63a84921 spi: pxa2xx: Remove CONFIG_SPI_PXA2XX_DMA f218d99d91ad spi: pxa2xx: Remove redundant call to lpss_ssp_setup() in probe c02fa78f26b3 spi: pxa2xx: Rework self-initiated platform data creation for non-ACPI 7e576a63daf8 spi: pxa2xx: Add support for Intel Broxton 5afb534233ea spi: pxa2xx: Detect number of enabled Intel LPSS SPI chip select signals 9dfe49803d54 spi: pxa2xx: Add output control for multiple Intel LPSS chip selects c3ea9f8cb427 spi: pxa2xx: Use LPSS prefix for defines that are Intel LPSS specific 769387d447c6 spi: pxa2xx: Align a few defines c4d5f4b2c5e1 spi: pxa2xx: Save other reg_cs_ctrl bits when configuring chip select cef6fd04c480 spi: pxa2xx: Convert unique ID string of ACPI device as unsigned integer 5cd1fcbbe756 spi: pxa2xx: move debug messages to pump_transfer() 86d77af087c1 spi: pxa2xx: choose closest lower speed b92f9ddf2a03 spi: pxa2xx: Remove unused psp member variable from struct chip_data eead50ab6d02 spi: pxa2xx: Remove empty function pxa2xx_spi_dma_resume() 59956c05a4c1 spi: pxa2xx: Use ACPI_COMPANION() instead of acpi_bus_get_device() 362498a7e09b spi: pxa2xx: Set the max_speed_hz of the master 34b9b6d72a6e spi: pxa2xx: Remove cr0 variable from struct chip_data 906a045e325a spi: pxa2xx: Remove if statement that is always true in pump_transfers() 9dcbad25be03 spi: pxa2xx: Remove two variables from struct chip_data 3a166657678e spi: pxa2xx: Add terminating entry for pxa2xx_spi_pci_compound_match f8912dd06280 spi: spi-pxa2xx: Remove unused legacy PXA DMA API channel numbers b75adec5ab03 spi: pxa2xx: Add support for Intel Sunrisepoint 54f13620b12e spi: spi-pxa2xx: Remove clk.h include c4dcefa9a892 spi: pxa2xx: Constify ACPI device ids e1deb5e11adc spi: spi-pxa2xx: remove legacy PXA DMA bits 1cae65e20310 spi: pxa2xx: Make LPSS SPI general register optional dffc716a7725 spi: pxa2xx: Prepare for new Intel LPSS SPI type 9641b2e46b6a spi: pxa2xx: Differentiate Intel LPSS types Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 304b0dd2ef..521eff4124 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt/base"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "8380fdf86b5d1ff542153e647f2ded0026a91852"
+SRCREV_machine ?= "28d8cfdbcb18a6eef202099cca66430fd3b6eae0"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 22a8dbee4b..62cf57d495 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.18"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "f5b08e95bc03f9819fa9d7ff57c698fbe2c16cc5"
+SRCREV_machine ?= "91f62d4a0a31919d9b2ccdaf881130f99b61fc5e"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index 5682b66a12..d8e864394f 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "75d5fa3b94efe0eb2101946d51015ce5bdc126cf"
-SRCREV_machine_qemuarm64 ?= "f5b08e95bc03f9819fa9d7ff57c698fbe2c16cc5"
-SRCREV_machine_qemumips ?= "5b7969dfff341c7d81b3726e0bb100cafa1cbfa1"
-SRCREV_machine_qemuppc ?= "f5b08e95bc03f9819fa9d7ff57c698fbe2c16cc5"
-SRCREV_machine_qemux86 ?= "f5b08e95bc03f9819fa9d7ff57c698fbe2c16cc5"
-SRCREV_machine_qemux86-64 ?= "f5b08e95bc03f9819fa9d7ff57c698fbe2c16cc5"
-SRCREV_machine_qemumips64 ?= "a3a35132a724752464ee13b10432cbdb2a110404"
-SRCREV_machine ?= "f5b08e95bc03f9819fa9d7ff57c698fbe2c16cc5"
+SRCREV_machine_qemuarm ?= "232e2d88841c7e20857350275d80f5585ed93734"
+SRCREV_machine_qemuarm64 ?= "91f62d4a0a31919d9b2ccdaf881130f99b61fc5e"
+SRCREV_machine_qemumips ?= "7d3690c0762f11e038f14310a50ca1cdc813cc22"
+SRCREV_machine_qemuppc ?= "91f62d4a0a31919d9b2ccdaf881130f99b61fc5e"
+SRCREV_machine_qemux86 ?= "91f62d4a0a31919d9b2ccdaf881130f99b61fc5e"
+SRCREV_machine_qemux86-64 ?= "91f62d4a0a31919d9b2ccdaf881130f99b61fc5e"
+SRCREV_machine_qemumips64 ?= "b71e4cd7d45f03048ad31e2a36dfe5a43f021b51"
+SRCREV_machine ?= "91f62d4a0a31919d9b2ccdaf881130f99b61fc5e"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \