aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-16 12:48:21 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 07:44:01 +0000
commit06ab1c7f60fbc0a9aebb9fd9321a1b7213378037 (patch)
treeb58a3047e432ec12c993f9d92aeda58171f6ac22 /meta/recipes-kernel/linux
parent9f3f15bcbfcca1581ead226892e9f02f9b6382c8 (diff)
downloadopenembedded-core-contrib-06ab1c7f60fbc0a9aebb9fd9321a1b7213378037.tar.gz
linux-yocto/4.1: usb: add usb_otg_caps to usb_gadget structure.
We backported a series of usb OTG commits for BSPs that required updated support, but this commit was missed. We backport it as well to fix build issues in some configurations. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index bd4fbbd33d..48f304dd2f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt/base"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "fe96b2fe1c896675ef3b62d2aae9ec2082a48899"
+SRCREV_machine ?= "5984d68470257f07d515b94570cd4fbdc5439380"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 1002b29ae7..3de6f0efbd 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.18"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "9073fd86a770707cceb817867460db72eaa9f107"
+SRCREV_machine ?= "304caa9480f19875e717faf3cad8cb7ecd758733"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index ff82047c54..a99ba9a160 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "3c2c6e8e8b528b9be1e034975623fd98e51bfc52"
-SRCREV_machine_qemuarm64 ?= "9073fd86a770707cceb817867460db72eaa9f107"
-SRCREV_machine_qemumips ?= "bee0b4b4981c34ea515758d0da3ad68012b8d0bf"
-SRCREV_machine_qemuppc ?= "9073fd86a770707cceb817867460db72eaa9f107"
-SRCREV_machine_qemux86 ?= "9073fd86a770707cceb817867460db72eaa9f107"
-SRCREV_machine_qemux86-64 ?= "9073fd86a770707cceb817867460db72eaa9f107"
-SRCREV_machine_qemumips64 ?= "600bca3cd7994a86ce1899132d1665ae0290c67a"
-SRCREV_machine ?= "9073fd86a770707cceb817867460db72eaa9f107"
+SRCREV_machine_qemuarm ?= "694cc606807a8e5cce762027f51b4179520c9238"
+SRCREV_machine_qemuarm64 ?= "304caa9480f19875e717faf3cad8cb7ecd758733"
+SRCREV_machine_qemumips ?= "9150f6c42a7f3d61c150dd0cc2f2de8749dceac9"
+SRCREV_machine_qemuppc ?= "304caa9480f19875e717faf3cad8cb7ecd758733"
+SRCREV_machine_qemux86 ?= "304caa9480f19875e717faf3cad8cb7ecd758733"
+SRCREV_machine_qemux86-64 ?= "304caa9480f19875e717faf3cad8cb7ecd758733"
+SRCREV_machine_qemumips64 ?= "e068452acbc753215c7e26d4e81cdf437b53b988"
+SRCREV_machine ?= "304caa9480f19875e717faf3cad8cb7ecd758733"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \