aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-03-16 12:48:17 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 07:44:01 +0000
commit46d173949675dde10b714f30b6f9c37c2e26a43a (patch)
treef3890748f6e6085db750ae75edc6bac56dc29235 /meta/recipes-kernel/linux
parentb8b778345eb0997c2cd952a1f61fdd2050b6b894 (diff)
downloadopenembedded-core-contrib-46d173949675dde10b714f30b6f9c37c2e26a43a.tar.gz
linux-yocto/4.1: usb backports for Apollo Lake/Broxton
Importing a series of mainline backports to support USB on a couple of Intel platforms: b5f6aa9957dd usb: otg: add usb_otg_caps structure for otg capabilities bbce8fe2cc42 usb: dwc3: pci: add support for Intel Broxton SOC e734e1d9f827 usb: dwc3: pci: Set enblslpm quirk for Synopsys platforms 1c6bb6694d50 usb: dwc3: Add dis_enblslpm_quirk 1c6be99e56b8 usb: dwc3: pci: trivial: Formatting 2f2b89764b97 usb: dwc3: pci: passing forward the ACPI companion ea4b3c72d976 usb: dwc3: core: convert to unified device property interface dc670b52c69a usb: common: of_usb_get_dr_mode to usb_get_dr_mode 586fc5174649 usb: dwc3: st: prepare the driver for generic usb_get_dr_mode function 0624bd9af7ef usb: common: of_usb_get_maximum_speed to usb_get_maximum_speed e65bc5467e07 usb: dwc3: Add frame length adjustment quirk a90954c5d267 usb: musb: dsps: control musb speed based on dts setting b48ff160a993 usb: renesas_usbhs: Allow an OTG PHY driver to provide VBUS d1c59752195e usb: chipidea: set usb otg capabilities 733eada2cdec usb: common: add API to update usb otg capabilities by device tree 7ab2108dd82b usb: dwc3: core: avoid NULL pointer dereference 1aedb48b7dc9 usb: dwc3: add ULPI interface support 07e42a29fb7e usb: dwc3: pci: add quirk for Baytrails 065917252622 usb: dwc3: add hsphy_interface property b2bb32a363a3 usb: dwc3: setup phys earlier bf6bb0a6ebb5 usb: dwc3: soft reset to it's own function d481da949476 usb: dwc3: cache hwparams earlier 9ac66262a201 usb: dwc3: store driver data earlier 5f940588938c usb: dwc3: ULPI or UTMI+ select 04fdce097f83 usb: dwc3: USB2 PHY register access bits b7209213cc05 usb: add bus type for USB ULPI Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb18
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 4a6928a7d1..4d9f5fbff8 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -2,8 +2,8 @@ KBRANCH ?= "standard/preempt-rt/base"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "2a4c22b03d434f7695e607b6ad30f77671985a6d"
-SRCREV_meta ?= "56dcb623ebf5e83d65fdb4eb270f23676bb000a5"
+SRCREV_machine ?= "0872aaf9d3a4b718ba6ad17a7706843cb556992d"
+SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 41a79f17b7..b2fac8a357 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.1.18"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
-SRCREV_meta ?= "56dcb623ebf5e83d65fdb4eb270f23676bb000a5"
+SRCREV_machine ?= "b5f6aa9957ddc28eafede6678b4c9ff49240bc19"
+SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index 9663966d8e..9093590f8b 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "96b21aab2adf2c9396f8cf579420a2e497923eae"
-SRCREV_machine_qemuarm64 ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
-SRCREV_machine_qemumips ?= "e0a6ffb62a4d28659e0e1be7b1a42a8ef499aa3b"
-SRCREV_machine_qemuppc ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
-SRCREV_machine_qemux86 ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
-SRCREV_machine_qemux86-64 ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
-SRCREV_machine_qemumips64 ?= "1b1349ca5a642086d4b92347fb9d1de1c6eab742"
-SRCREV_machine ?= "ec18b0b3bd6befd416078e81d775dab37b3f9124"
-SRCREV_meta ?= "56dcb623ebf5e83d65fdb4eb270f23676bb000a5"
+SRCREV_machine_qemuarm ?= "2b83b94ab36113da6d63e525e0686d1e9fefbeca"
+SRCREV_machine_qemuarm64 ?= "b5f6aa9957ddc28eafede6678b4c9ff49240bc19"
+SRCREV_machine_qemumips ?= "a5c91d6ff822f3920fd9a20b0deefa6e23acef32"
+SRCREV_machine_qemuppc ?= "b5f6aa9957ddc28eafede6678b4c9ff49240bc19"
+SRCREV_machine_qemux86 ?= "b5f6aa9957ddc28eafede6678b4c9ff49240bc19"
+SRCREV_machine_qemux86-64 ?= "b5f6aa9957ddc28eafede6678b4c9ff49240bc19"
+SRCREV_machine_qemumips64 ?= "2299caefd7d36e0fe868316045ceb58b9ae369f9"
+SRCREV_machine ?= "b5f6aa9957ddc28eafede6678b4c9ff49240bc19"
+SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"