aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-08-24 10:59:55 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-28 10:27:15 +0100
commit8a0c315d21bb6783b55ecc73ec48274da0ceff43 (patch)
treef7f014ce2c5ba1e17509d577ef99b69a15dd83e5 /meta/recipes-kernel/linux
parenta08dac36a04e7fa1c14c9a770cabe1a0d9386b1a (diff)
downloadopenembedded-core-contrib-8a0c315d21bb6783b55ecc73ec48274da0ceff43.tar.gz
linux-yocto: add selftest and security configuration blocks
Adding two new configuration blocks/features to the 4.14+ kernel variants. One is for enabling selftest options, and the other is a collection of kernel security/hardening configs. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.15.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
index 9e4d353cfb..24e3f07036 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "517929399b9fd48c9e86fe6724097532ff779f9b"
-SRCREV_meta ?= "f97272690ca7e1143b9db3c1f1a01d9c37b6f478"
+SRCREV_meta ?= "8a3be7d783a39b56796e1d5197cb9f757e38f22f"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb
index 26d8382b38..75aa21055f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.15.bb
@@ -12,7 +12,7 @@ python () {
}
SRCREV_machine ?= "3373c0cf71f2812eeb9694839456df6f67fd32ac"
-SRCREV_meta ?= "3b43c318d9dca8858e0ec402db8a99ab2b79f16f"
+SRCREV_meta ?= "4f95b5be8ca7af984b4abee7f6f9eeccd136a5cb"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.15;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
index ecb7b43726..05ce90c2e8 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
@@ -13,7 +13,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "2b98ddc7546b7c880361c9e13e1c11393fb8b0e1"
-SRCREV_meta ?= "f97272690ca7e1143b9db3c1f1a01d9c37b6f478"
+SRCREV_meta ?= "8a3be7d783a39b56796e1d5197cb9f757e38f22f"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
index d3759b0582..392fc1c38a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
@@ -11,7 +11,7 @@ KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
SRCREV_machine ?= "3373c0cf71f2812eeb9694839456df6f67fd32ac"
-SRCREV_meta ?= "3b43c318d9dca8858e0ec402db8a99ab2b79f16f"
+SRCREV_meta ?= "4f95b5be8ca7af984b4abee7f6f9eeccd136a5cb"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.14.bb b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
index 22c7b1e696..02c42c4008 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "1839f1b10cf9895ac0e31631eaa9a5ed5c63ede0"
SRCREV_machine_qemux86-64 ?= "1839f1b10cf9895ac0e31631eaa9a5ed5c63ede0"
SRCREV_machine_qemumips64 ?= "db539ae62da0b5fe7d065830c2709abc01a5591d"
SRCREV_machine ?= "1839f1b10cf9895ac0e31631eaa9a5ed5c63ede0"
-SRCREV_meta ?= "f97272690ca7e1143b9db3c1f1a01d9c37b6f478"
+SRCREV_meta ?= "8a3be7d783a39b56796e1d5197cb9f757e38f22f"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.15.bb b/meta/recipes-kernel/linux/linux-yocto_4.15.bb
index 238d35a3c8..14afc41c20 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.15.bb
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "3373c0cf71f2812eeb9694839456df6f67fd32ac"
SRCREV_machine_qemux86-64 ?= "3373c0cf71f2812eeb9694839456df6f67fd32ac"
SRCREV_machine_qemumips64 ?= "b98c113571c72a0d34832dd6fe5585529b32988b"
SRCREV_machine ?= "3373c0cf71f2812eeb9694839456df6f67fd32ac"
-SRCREV_meta ?= "3b43c318d9dca8858e0ec402db8a99ab2b79f16f"
+SRCREV_meta ?= "4f95b5be8ca7af984b4abee7f6f9eeccd136a5cb"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.15;destsuffix=${KMETA}"