summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-09-29 16:04:45 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-10-01 08:11:27 +0100
commit9151757f43d00dd3092e61a6aca669335c8ecf63 (patch)
tree539cf105745775462695310e3ae7a3245fe69832 /meta/recipes-kernel/linux
parent6f87d8e92fc3d5229eb0f8c33548dd147c03a0ce (diff)
downloadopenembedded-core-contrib-9151757f43d00dd3092e61a6aca669335c8ecf63.tar.gz
linux-yocto/6.4: update to v6.4.15
Updating to the latest korg -stable release that comprises the following commits: f60d5fd5e950 Linux 6.4.15 12ac1448ab77 pinctrl: amd: Don't show `Invalid config param` errors 120e477de917 usb: typec: tcpci: clear the fault status bit 46c11be2dca2 nilfs2: fix WARNING in mark_buffer_dirty due to discarded buffer reuse d53a0a737639 dt-bindings: sc16is7xx: Add property to change GPIO function f75a9a53327b tcpm: Avoid soft reset when partner does not support get_status c95605d5ed23 fsi: master-ast-cf: Add MODULE_FIRMWARE macro 4c0dc67881c6 firmware: stratix10-svc: Fix an NULL vs IS_ERR() bug in probe 43b5cedc3564 serial: sc16is7xx: fix bug when first setting GPIO direction e534d3e986fc serial: sc16is7xx: fix broken port 0 uart init e02214399ef4 serial: qcom-geni: fix opp vote on shutdown 2f2b1f63a760 wifi: ath11k: Cleanup mac80211 references on failure during tx_complete f6909803263c wifi: ath11k: Don't drop tx_status when peer cannot be found c32e118debe9 wifi: rtw88: usb: kill and free rx urbs on probe failure e74778e91fed wifi: mt76: mt7921: fix skb leak by txs missing in AMSDU 046378bdf9de wifi: mt76: mt7921: do not support one stream on secondary antenna only 18a9d16f2fbe staging: rtl8712: fix race condition 5db7c0f7fb51 HID: wacom: remove the battery when the EKR is off ae3f94d539a3 usb: chipidea: imx: improve logic if samsung,picophy-* parameter is 0 ce06713e64e3 usb: dwc3: meson-g12a: do post init to fix broken usb after resumption 596b16ee3f9a ALSA: usb-audio: Fix init call orders for UAC1 c72b4c1c2407 USB: serial: option: add FOXCONN T99W368/T99W373 product 7114ed5e53b0 USB: serial: option: add Quectel EM05G variant (0x030e) 784a1fd76b74 modules: only allow symbol_get of EXPORT_SYMBOL_GPL modules f2114d34d6bb rtc: ds1685: use EXPORT_SYMBOL_GPL for ds1685_rtc_poweroff 68a2c15de311 net: enetc: use EXPORT_SYMBOL_GPL for enetc_phc_index 95dca60f39a6 mmc: au1xmmc: force non-modular build and remove symbol_get usage 245bc3e5329e ARM: pxa: remove use of symbol_get() 1c660940f525 ksmbd: reduce descriptor size if remaining bytes is less than request size 1a13ecb96230 ksmbd: replace one-element array with flex-array member in struct smb2_ea_info 7f1d6cb0eb6a ksmbd: fix slub overflow in ksmbd_decode_ntlmssp_auth_blob() a43bf41344d0 ksmbd: fix wrong DataOffset validation of create context 9535cd211933 erofs: ensure that the post-EOF tails are all zeroed Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/cve-exclusion_6.4.inc18
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb6
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb6
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.4.bb28
4 files changed, 35 insertions, 23 deletions
diff --git a/meta/recipes-kernel/linux/cve-exclusion_6.4.inc b/meta/recipes-kernel/linux/cve-exclusion_6.4.inc
index d64ab0092d..7bffaa70e1 100644
--- a/meta/recipes-kernel/linux/cve-exclusion_6.4.inc
+++ b/meta/recipes-kernel/linux/cve-exclusion_6.4.inc
@@ -1,9 +1,9 @@
# Auto-generated CVE metadata, DO NOT EDIT BY HAND.
-# Generated at 2023-09-19 16:30:35.921888+00:00 for version 6.4.14
+# Generated at 2023-09-30 07:22:32.115009+00:00 for version 6.4.15
python check_kernel_cve_status_version() {
- this_version = "6.4.14"
+ this_version = "6.4.15"
kernel_version = d.getVar("LINUX_VERSION")
if kernel_version != this_version:
bb.warn("Kernel CVE status needs updating: generated for %s but kernel is %s" % (this_version, kernel_version))
@@ -3450,6 +3450,8 @@ CVE_STATUS[CVE-2020-36691] = "fixed-version: Fixed from version 5.8rc1"
CVE_STATUS[CVE-2020-36694] = "fixed-version: Fixed from version 5.10"
+CVE_STATUS[CVE-2020-36766] = "fixed-version: Fixed from version 5.9rc1"
+
CVE_STATUS[CVE-2020-3702] = "fixed-version: Fixed from version 5.12rc1"
CVE_STATUS[CVE-2020-4788] = "fixed-version: Fixed from version 5.10rc5"
@@ -4644,7 +4646,7 @@ CVE_STATUS[CVE-2023-1192] = "fixed-version: Fixed from version 6.4rc1"
# CVE-2023-1193 has no known resolution
-# CVE-2023-1194 has no known resolution
+CVE_STATUS[CVE-2023-1194] = "fixed-version: Fixed from version 6.4rc6"
CVE_STATUS[CVE-2023-1195] = "fixed-version: Fixed from version 6.1rc3"
@@ -5034,6 +5036,12 @@ CVE_STATUS[CVE-2023-4244] = "cpe-stable-backport: Backported in 6.4.12"
CVE_STATUS[CVE-2023-4273] = "cpe-stable-backport: Backported in 6.4.10"
+# CVE-2023-42752 needs backporting (fixed from 6.4.16)
+
+# CVE-2023-42753 needs backporting (fixed from 6.4.16)
+
+CVE_STATUS[CVE-2023-42755] = "fixed-version: Fixed from version 6.3rc1"
+
CVE_STATUS[CVE-2023-4385] = "fixed-version: Fixed from version 5.19rc1"
CVE_STATUS[CVE-2023-4387] = "fixed-version: Fixed from version 5.18"
@@ -5058,3 +5066,7 @@ CVE_STATUS[CVE-2023-4611] = "cpe-stable-backport: Backported in 6.4.8"
# CVE-2023-4921 needs backporting (fixed from 6.6rc1)
+# CVE-2023-5158 has no known resolution
+
+# CVE-2023-5197 needs backporting (fixed from 6.6rc3)
+
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
index aacbea40c0..07e852d584 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
@@ -14,13 +14,13 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "06b99074bdc85095a2b3411dcade4a64a8e8f7c0"
-SRCREV_meta ?= "f12230a4c8a427af642be8196828a23f4562bc86"
+SRCREV_machine ?= "40f6eb23017e1bb31c63e980b6d11bc8e917824b"
+SRCREV_meta ?= "b1e8a40393e0ac784e05a45ee90b6680e3b53263"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.4;destsuffix=${KMETA};protocol=https"
-LINUX_VERSION ?= "6.4.14"
+LINUX_VERSION ?= "6.4.15"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
index c3a7a16342..74b830afb4 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
@@ -8,7 +8,7 @@ require recipes-kernel/linux/linux-yocto.inc
# CVE exclusions
include recipes-kernel/linux/cve-exclusion_6.4.inc
-LINUX_VERSION ?= "6.4.14"
+LINUX_VERSION ?= "6.4.15"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
@@ -17,8 +17,8 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_meta ?= "f12230a4c8a427af642be8196828a23f4562bc86"
+SRCREV_machine ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_meta ?= "b1e8a40393e0ac784e05a45ee90b6680e3b53263"
PV = "${LINUX_VERSION}+git"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.4.bb b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
index e959b2a88f..d17f05eba4 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
@@ -18,25 +18,25 @@ KBRANCH:qemux86-64 ?= "v6.4/standard/base"
KBRANCH:qemuloongarch64 ?= "v6.4/standard/base"
KBRANCH:qemumips64 ?= "v6.4/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "0194f88dc4ac51536f9bb2bf751d256bc5fe5d69"
-SRCREV_machine:qemuarm64 ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_machine:qemuloongarch64 ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_machine:qemumips ?= "179200623f949dde2afeca75943700a2cd0684ab"
-SRCREV_machine:qemuppc ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_machine:qemuriscv64 ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_machine:qemuriscv32 ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_machine:qemux86 ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_machine:qemux86-64 ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_machine:qemumips64 ?= "4ce1ab0a4fce437802b0f7305289b036ffb4ccae"
-SRCREV_machine ?= "800df81fa2a8bacd6487a19115b3f89f34620249"
-SRCREV_meta ?= "f12230a4c8a427af642be8196828a23f4562bc86"
+SRCREV_machine:qemuarm ?= "47cff83414374714b911719ba588aa6e2816956b"
+SRCREV_machine:qemuarm64 ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_machine:qemuloongarch64 ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_machine:qemumips ?= "d3a6c87612629a4c1f722b7d93e9a04aec7b22a4"
+SRCREV_machine:qemuppc ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_machine:qemuriscv64 ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_machine:qemuriscv32 ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_machine:qemux86 ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_machine:qemux86-64 ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_machine:qemumips64 ?= "da59fe1c279b1be0b6b51dc503fe6500fdf84671"
+SRCREV_machine ?= "3f60b22a4257993a1e389d46d1204a0f580fc99e"
+SRCREV_meta ?= "b1e8a40393e0ac784e05a45ee90b6680e3b53263"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same
# meta SRCREV as the linux-yocto-standard builds. Select your version using the
# normal PREFERRED_VERSION settings.
BBCLASSEXTEND = "devupstream:target"
-SRCREV_machine:class-devupstream ?= "babc8be398c3a0701e52582f93bfba946e9e5f8e"
+SRCREV_machine:class-devupstream ?= "f60d5fd5e950c89a38578ae6f25877de511bb031"
PN:class-devupstream = "linux-yocto-upstream"
KBRANCH:class-devupstream = "v6.4/base"
@@ -44,7 +44,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRA
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.4;destsuffix=${KMETA};protocol=https"
LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
-LINUX_VERSION ?= "6.4.14"
+LINUX_VERSION ?= "6.4.15"
PV = "${LINUX_VERSION}+git"