aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-22 16:22:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-26 08:56:26 +0100
commitcea867b5320907b73e3934147ee6d1efc4b1cf3a (patch)
treec0f338c5f462b13702dfa4e9a160226a43df56e2 /meta/recipes-kernel/linux
parente1fcb032e2356fa54d9f15b819660c3fb60b85fa (diff)
downloadopenembedded-core-contrib-cea867b5320907b73e3934147ee6d1efc4b1cf3a.tar.gz
linux-yocto-dev: Ensure we don't reparse the recipe when its not being used (take 2)
The use of the ${AUTOREV} variable means bitbake would always re-parse the recipe. This isn't desirable when its disabled so undo the always parsing flag in this case. (From OE-Core rev: f1fce69766576ab62bfc5919af2af04028180950) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 3085263453..c7773506a6 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -19,6 +19,7 @@ include recipes-kernel/linux/linux-yocto-dev-revisions.inc
# by the use of AUTOREV SRCREVs, which are the default for this recipe.
python () {
if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
+ d.delVar("BB_DONT_CACHE")
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
}