aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-08 18:00:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-12 23:10:14 +0100
commit3e0137113e894eb8b23cd43721c7ba26ff234c8f (patch)
tree5dc6a188821818b19f8d6ffec9c79cf5816e4453 /meta/recipes-kernel/linux
parent6deadf5498d091462b92a261e5467f2f754d4921 (diff)
downloadopenembedded-core-contrib-3e0137113e894eb8b23cd43721c7ba26ff234c8f.tar.gz
linux-yocto-dev: Handle performance regression
After commit 0437a59e3c298d40aaa96af09b80bff8fcbe292d, the linux-yocto-dev recipe is being parsed every time we run "bitbake -p". This was spotted on some performance benchmarks and showed up as a performance regression. We can tweak the recipe to ensure this doesn't happen and that its only used if selected. (From OE-Core rev: 5c21fd5eb8b689504e7f6a4ee2f674c32e3d928b) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 3085263453..c50b319ec6 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -20,6 +20,9 @@ include recipes-kernel/linux/linux-yocto-dev-revisions.inc
python () {
if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
+ else:
+ d.setVar("SRCREV_machine", "${AUTOREV}")
+ d.setVar("SRCREV_meta", "${AUTOREV}")
}
KBRANCH = "standard/base"
@@ -33,8 +36,8 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name
# linux-yocto-dev is the preferred provider, they will be overridden to
# AUTOREV in following anonymous python routine and resolved when the
# variables are finalized.
-SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
-SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
+SRCREV_machine ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
+SRCREV_meta ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
LINUX_VERSION ?= "4.6-rc+"
LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"