aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-11-15 11:25:58 -0500
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:22 -0800
commitc70816cb9022dfedd78817bb1dfe20219fe2dd90 (patch)
tree764704dc00eacf53e7a276a0840a32c71160f27f /meta/recipes-kernel/linux
parent771d890d086534536ff4aa4a386f17e2b697c0be (diff)
downloadopenembedded-core-contrib-c70816cb9022dfedd78817bb1dfe20219fe2dd90.tar.gz
linux-wrs: rename to linux-yocto
The existing preferred yocto kernel wasn't named appropriately and needs to be updated. In keeping the changes small and isolated, this commit simply renames the recipe and some internal variables. Future commits will refactor the code into more usable blocks. Now that linuy-wrs has been renamed linux-yocto, we need to rename and update an board configurations and append files. Now that linux-wrs has been renamed linux-yocto, we need to update the SRCREVs to have the new name. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb (renamed from meta/recipes-kernel/linux/linux-wrs_git.bb)73
1 files changed, 37 insertions, 36 deletions
diff --git a/meta/recipes-kernel/linux/linux-wrs_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index 209648b8e7..ef005aefca 100644
--- a/meta/recipes-kernel/linux/linux-wrs_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "Wind River Kernel"
+DESCRIPTION = "Yocto Kernel"
SECTION = "kernel"
LICENSE = "GPL"
@@ -13,16 +13,17 @@ PV = "2.6.34+git${SRCPV}"
SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta"
-WRMACHINE = "UNDEFINED"
-WRMACHINE_qemux86 = "common_pc"
-WRMACHINE_qemux86-64 = "common_pc_64"
-WRMACHINE_qemuppc = "qemu_ppc32"
-WRMACHINE_qemumips = "mti_malta32_be"
-WRMACHINE_qemuarm = "arm_versatile_926ejs"
-WRMACHINE_atom-pc = "atom-pc"
-WRMACHINE_routerstationpro = "routerstationpro"
-WRMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
-WRMACHINE_beagleboard = "beagleboard"
+# map the poky machine to a 'kernel machine'
+KMACHINE = "UNDEFINED"
+KMACHINE_qemux86 = "common_pc"
+KMACHINE_qemux86-64 = "common_pc_64"
+KMACHINE_qemuppc = "qemu_ppc32"
+KMACHINE_qemumips = "mti_malta32_be"
+KMACHINE_qemuarm = "arm_versatile_926ejs"
+KMACHINE_atom-pc = "atom-pc"
+KMACHINE_routerstationpro = "routerstationpro"
+KMACHINE_mpc8315e-rdb = "fsl-mpc8315e-rdb"
+KMACHINE_beagleboard = "beagleboard"
# Determine which branch to fetch and build. Not all branches are in the
# upstream repo (but will be locally created after the fetchers run) so
@@ -36,11 +37,11 @@ WRMACHINE_beagleboard = "beagleboard"
python __anonymous () {
import bb, re
- bb.data.setVar("KBRANCH", "${WRMACHINE}-${LINUX_KERNEL_TYPE}", d)
- mach = bb.data.getVar("WRMACHINE", d, 1)
+ bb.data.setVar("KBRANCH", "${KMACHINE}-${LINUX_KERNEL_TYPE}", d)
+ mach = bb.data.getVar("KMACHINE", d, 1)
if mach == "UNDEFINED":
bb.data.setVar("KBRANCH", "standard", d)
- bb.data.setVar("WRMACHINE", "${MACHINE}", d)
+ bb.data.setVar("KMACHINE", "${MACHINE}", d)
# track the global configuration on a bootstrapped BSP
bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d)
bb.data.setVar("BOOTSTRAP", "t", d)
@@ -53,7 +54,7 @@ LINUX_VERSION_EXTENSION = "-wr-${LINUX_KERNEL_TYPE}"
PR = "r13"
S = "${WORKDIR}/linux"
-B = "${WORKDIR}/linux-${WRMACHINE}-${LINUX_KERNEL_TYPE}-build"
+B = "${WORKDIR}/linux-${KMACHINE}-${LINUX_KERNEL_TYPE}-build"
# functionality flags
KERNEL_REVISION_CHECKING ?= "t"
@@ -66,9 +67,9 @@ do_patch() {
fi
# simply ensures that a branch of the right name has been created
- createme ${ARCH} ${WRMACHINE}-${LINUX_KERNEL_TYPE} ${defconfig}
+ createme ${ARCH} ${KMACHINE}-${LINUX_KERNEL_TYPE} ${defconfig}
if [ $? -ne 0 ]; then
- echo "ERROR. Could not create ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
+ echo "ERROR. Could not create ${KMACHINE}-${LINUX_KERNEL_TYPE}"
exit 1
fi
@@ -78,14 +79,14 @@ do_patch() {
fi
updateme ${addon_features} ${ARCH} ${WORKDIR}
if [ $? -ne 0 ]; then
- echo "ERROR. Could not update ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
+ echo "ERROR. Could not update ${KMACHINE}-${LINUX_KERNEL_TYPE}"
exit 1
fi
# executes and modifies the source tree as required
- patchme ${WRMACHINE}-${LINUX_KERNEL_TYPE}
+ patchme ${KMACHINE}-${LINUX_KERNEL_TYPE}
if [ $? -ne 0 ]; then
- echo "ERROR. Could not modify ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
+ echo "ERROR. Could not modify ${KMACHINE}-${LINUX_KERNEL_TYPE}"
exit 1
fi
}
@@ -100,9 +101,9 @@ validate_branches() {
if [ -n "${KERNEL_REVISION_CHECKING}" ]; then
git show ${target_branch_head} > /dev/null 2>&1
if [ $? -eq 0 ]; then
- echo "Forcing branch ${WRMACHINE}-${LINUX_KERNEL_TYPE} to ${target_branch_head}"
- git branch -m ${WRMACHINE}-${LINUX_KERNEL_TYPE} ${WRMACHINE}-${LINUX_KERNEL_TYPE}-orig
- git checkout -b ${WRMACHINE}-${LINUX_KERNEL_TYPE} ${target_branch_head}
+ echo "Forcing branch ${KMACHINE}-${LINUX_KERNEL_TYPE} to ${target_branch_head}"
+ git branch -m ${KMACHINE}-${LINUX_KERNEL_TYPE} ${KMACHINE}-${LINUX_KERNEL_TYPE}-orig
+ git checkout -b ${KMACHINE}-${LINUX_KERNEL_TYPE} ${target_branch_head}
else
echo "ERROR ${target_branch_head} is not a valid commit ID."
echo "The kernel source tree may be out of sync"
@@ -127,9 +128,9 @@ validate_branches() {
fi
}
-do_wrlinux_checkout() {
+do_kernel_checkout() {
if [ -d ${WORKDIR}/.git/refs/remotes/origin ]; then
- echo "Fixing up git directory for ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
+ echo "Fixing up git directory for ${KMACHINE}-${LINUX_KERNEL_TYPE}"
rm -rf ${S}
mkdir ${S}
mv ${WORKDIR}/.git ${S}
@@ -165,17 +166,17 @@ IFS='
# our initial checkout. So we do it a second time to be sure
git checkout -f ${KBRANCH}
}
-do_wrlinux_checkout[dirs] = "${S}"
+do_kernel_checkout[dirs] = "${S}"
-addtask wrlinux_checkout before do_patch after do_unpack
+addtask kernel_checkout before do_patch after do_unpack
-do_wrlinux_configme() {
- echo "Doing wrlinux configme"
+do_kernel_configme() {
+ echo "Doing kernel configme"
cd ${S}
configme --reconfig
if [ $? -ne 0 ]; then
- echo "ERROR. Could not configure ${WRMACHINE}-${LINUX_KERNEL_TYPE}"
+ echo "ERROR. Could not configure ${KMACHINE}-${LINUX_KERNEL_TYPE}"
exit 1
fi
@@ -184,13 +185,13 @@ do_wrlinux_configme() {
echo "CONFIG_LOCALVERSION="\"${LINUX_VERSION_EXTENSION}\" >> ${B}/.config
}
-do_wrlinux_configcheck() {
+do_kernel_configcheck() {
echo "[INFO] validating kernel configuration"
cd ${B}/..
- kconf_check ${B}/.config ${B} ${S} ${B} ${LINUX_VERSION} ${WRMACHINE}-${LINUX_KERNEL_TYPE}
+ kconf_check ${B}/.config ${B} ${S} ${B} ${LINUX_VERSION} ${KMACHINE}-${LINUX_KERNEL_TYPE}
}
-do_wrlinux_link_vmlinux() {
+do_kernel_link_vmlinux() {
if [ ! -d "${B}/arch/${ARCH}/boot" ]; then
mkdir ${B}/arch/${ARCH}/boot
fi
@@ -207,9 +208,9 @@ do_install_perf() {
}
do_patch[depends] = "kern-tools-native:do_populate_sysroot"
-addtask wrlinux_configme before do_configure after do_patch
-addtask wrlinux_link_vmlinux after do_compile before do_install
-addtask wrlinux_configcheck after do_configure before do_compile
+addtask kernel_configme before do_configure after do_patch
+addtask kernel_link_vmlinux after do_compile before do_install
+addtask kernel_configcheck after do_configure before do_compile
inherit kernel