aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-04-25 12:29:44 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-09 08:03:58 +0100
commit802758b2ade24040d16ce4b692a07f97bef39331 (patch)
tree8c41d51114e105e1907772d8abad23f172409b9d /meta/recipes-kernel/linux/linux-yocto_4.4.bb
parent7071ab47ce566398b398ac3d24eb3620a0353897 (diff)
downloadopenembedded-core-contrib-802758b2ade24040d16ce4b692a07f97bef39331.tar.gz
linux-yocto/4.4: BXT mmc fixes + PUNIT, tubropower, and telemetry backport
Integrating the following mainline (or mainline destined) patches to support Intel Broxton: 076cc85486fd mmc: sdhci-acpi: Set MMC_CAP_AGGRESSIVE_PM for Broxton controllers 5d9c3aba78a1 mmc: sdhci-pci: Remove redundant runtime PM calls aa0cd9a58d54 mmc: sdhci: Fix sdhci_runtime_pm_bus_on/off() f47597d00af0 mmc: sdhci: 64-bit DMA actually has 4-byte alignment a052a0703aed mmc: sdhci: Fix DMA descriptor with zero data length f9200dd4bfec mmc: sdio: Fix invalid vdd in voltage switch power cycle 7bbf49488269 mmc: sdhci: Do not BUG on invalid vdd 39fde8b630a6 tools/power turbostat: decode BXT TSC frequency via CPUID 2b4b633da512 tools/power turbostat: initial BXT support ee708ab5b74e intel_telemetry_debugfs: Fix unused warnings in telemetry debugfs 3053465d066b intel_telemetry_pltdrv: Change verbosity control bits 4c7732ec34bf platform:x86: Add Intel Telemetry Debugfs interfaces 401915397ddc platform:x86: Add Intel telemetry platform driver eaaee25ac936 platform/x86: Add Intel Telemetry Core Driver 44c969c62726 platform:x86 decouple telemetry driver from the optional IPC resources a6a2ecaf9980 platform:x86: Add Intel telemetry platform device e1f16b86eab0 intel_pmc_ipc: Avoid pending IPC1 command during legacy suspend ae91be46eb0d intel_pmc_ipc: Fix GCR register base address and length 3e15c1b19c81 intel_pmc_ipc: update acpi resource structure for Punit 5ec614cfd985 intel_punit_ipc: add NULL check for input parameters 4c3f01b178db platform:x86: add Intel P-Unit mailbox IPC driver 4826dbaac15f usb: dwc3: pci: add ID for one more Intel Broxton platform Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.4.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.4.bb b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
index ed1d04edb7..f81e3aee7f 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "8f6d6325fdb8c561804af8c13456e372d6bd3b5b"
-SRCREV_machine_qemuarm64 ?= "7a073202d4d47b5ffecf1e8f57b036f83b1fe2e0"
-SRCREV_machine_qemumips ?= "4bf7bd3c7df18f51bf422f625f1a6650bb456abd"
-SRCREV_machine_qemuppc ?= "7a073202d4d47b5ffecf1e8f57b036f83b1fe2e0"
-SRCREV_machine_qemux86 ?= "7a073202d4d47b5ffecf1e8f57b036f83b1fe2e0"
-SRCREV_machine_qemux86-64 ?= "7a073202d4d47b5ffecf1e8f57b036f83b1fe2e0"
-SRCREV_machine_qemumips64 ?= "91c6f056a0fd3bada9f67c0276107b37fd3f6846"
-SRCREV_machine ?= "7a073202d4d47b5ffecf1e8f57b036f83b1fe2e0"
+SRCREV_machine_qemuarm ?= "1882e842bd477d8a4de02e304a13d230b597d142"
+SRCREV_machine_qemuarm64 ?= "076cc85486fda808582bd1e77400a5c49dea3e2e"
+SRCREV_machine_qemumips ?= "3d1402582cd48731ccfaec497dd9296a59cda386"
+SRCREV_machine_qemuppc ?= "076cc85486fda808582bd1e77400a5c49dea3e2e"
+SRCREV_machine_qemux86 ?= "076cc85486fda808582bd1e77400a5c49dea3e2e"
+SRCREV_machine_qemux86-64 ?= "076cc85486fda808582bd1e77400a5c49dea3e2e"
+SRCREV_machine_qemumips64 ?= "6519e6317cc72e380bc1b7543e614ac0032a80ae"
+SRCREV_machine ?= "076cc85486fda808582bd1e77400a5c49dea3e2e"
SRCREV_meta ?= "e1515ef98cec975df218363e28c2abe3a71c6a59"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \